Fix missing function prototype definition
This commit is contained in:
parent
ceb62ca889
commit
85648f0a0d
8
debian/changelog
vendored
8
debian/changelog
vendored
|
@ -1,3 +1,11 @@
|
||||||
|
dns-flood-detector (1.10-4) unstable; urgency=low
|
||||||
|
|
||||||
|
* included fix_prototyp patch provided by "dann frazier <dannf@debian.org>"
|
||||||
|
(Closes: #399283).
|
||||||
|
* build depend to dpatch
|
||||||
|
|
||||||
|
-- Jan Wagner <waja@cyconet.org> Sun, 19 Nov 2006 10:18:55 +0100
|
||||||
|
|
||||||
dns-flood-detector (1.10-3) unstable; urgency=low
|
dns-flood-detector (1.10-3) unstable; urgency=low
|
||||||
|
|
||||||
* using killall in init script to get daemon stopped
|
* using killall in init script to get daemon stopped
|
||||||
|
|
2
debian/control
vendored
2
debian/control
vendored
|
@ -2,7 +2,7 @@ Source: dns-flood-detector
|
||||||
Section: net
|
Section: net
|
||||||
Priority: optional
|
Priority: optional
|
||||||
Maintainer: Jan Wagner <waja@cyconet.org>
|
Maintainer: Jan Wagner <waja@cyconet.org>
|
||||||
Build-Depends: debhelper (>= 5), libpcap0.8-dev
|
Build-Depends: debhelper (>= 5), dpatch, libpcap0.8-dev
|
||||||
Standards-Version: 3.7.2
|
Standards-Version: 3.7.2
|
||||||
|
|
||||||
Package: dns-flood-detector
|
Package: dns-flood-detector
|
||||||
|
|
1
debian/patches/00list
vendored
Normal file
1
debian/patches/00list
vendored
Normal file
|
@ -0,0 +1 @@
|
||||||
|
01_fix_prototyp.dpatch
|
31
debian/patches/01_fix_prototyp.dpatch
vendored
Executable file
31
debian/patches/01_fix_prototyp.dpatch
vendored
Executable file
|
@ -0,0 +1,31 @@
|
||||||
|
#!/bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 01_fix_prototyp.dpatch by dann frazier <dannf@debian.org>
|
||||||
|
##
|
||||||
|
## DP: fix missing function prototype definition
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
|
||||||
|
--- dns-flood-detector-1.10/dns_flood_detector.c~ 2003-12-29 20:53:38.000000000 -0700
|
||||||
|
+++ dns-flood-detector-1.10/dns_flood_detector.c 2006-11-18 17:38:47.000000000 -0700
|
||||||
|
@@ -79,11 +79,13 @@
|
||||||
|
#include <stdlib.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
#include <errno.h>
|
||||||
|
+#include <sys/socket.h>
|
||||||
|
#include <netinet/in_systm.h>
|
||||||
|
#include <netinet/in.h>
|
||||||
|
#include <netinet/ip.h>
|
||||||
|
#include <netinet/tcp.h>
|
||||||
|
#include <netinet/udp.h>
|
||||||
|
+#include <arpa/inet.h>
|
||||||
|
#ifdef __bsdi__
|
||||||
|
#include <net/if_ethernet.h>
|
||||||
|
#else
|
||||||
|
@@ -99,6 +101,7 @@
|
||||||
|
#include <math.h>
|
||||||
|
#include <signal.h>
|
||||||
|
#include <syslog.h>
|
||||||
|
+#include <string.h>
|
||||||
|
#include "dns_flood_detector.h"
|
||||||
|
|
||||||
|
// global variables and their defaults
|
6
debian/rules
vendored
6
debian/rules
vendored
|
@ -4,6 +4,8 @@
|
||||||
# Uncomment this to turn on verbose mode.
|
# Uncomment this to turn on verbose mode.
|
||||||
#export DH_VERBOSE=1
|
#export DH_VERBOSE=1
|
||||||
|
|
||||||
|
include /usr/share/dpatch/dpatch.make
|
||||||
|
|
||||||
CFLAGS += -D_BSD_SOURCE -Wall -g
|
CFLAGS += -D_BSD_SOURCE -Wall -g
|
||||||
LDLIBS += -lpcap -lpthread -lm
|
LDLIBS += -lpcap -lpthread -lm
|
||||||
|
|
||||||
|
@ -14,14 +16,14 @@ else
|
||||||
endif
|
endif
|
||||||
|
|
||||||
build: build-stamp
|
build: build-stamp
|
||||||
build-stamp:
|
build-stamp: patch-stamp
|
||||||
dh_testdir
|
dh_testdir
|
||||||
# Add here commands to compile the package.
|
# Add here commands to compile the package.
|
||||||
$(CC) $(CFLAGS) dns_flood_detector.c $(LDLIBS) -o dns_flood_detector
|
$(CC) $(CFLAGS) dns_flood_detector.c $(LDLIBS) -o dns_flood_detector
|
||||||
|
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
clean:
|
clean: unpatch
|
||||||
dh_testdir
|
dh_testdir
|
||||||
dh_testroot
|
dh_testroot
|
||||||
rm -f build-stamp
|
rm -f build-stamp
|
||||||
|
|
Loading…
Reference in a new issue