clarify that check_http won't verify certificates
This commit is contained in:
parent
0dd3b3534a
commit
0ae23aacdf
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -14,6 +14,8 @@ nagios-plugins (1.4.15-6) UNRELEASED; urgency=low
|
|||
* Add 18_check_snmp_labels.dpatch to fix multiple labels in check_snmp
|
||||
(Closes: #647020), thanks to Oskar Liljeblad
|
||||
* Updating Vcs-Browser field
|
||||
* Add 19_check_http_help.dpatch to clarify that check_http won't verify
|
||||
certificates (Closes: #644627), thanks to Michael Renner
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Wed, 07 Sep 2011 15:33:55 +0200
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -13,3 +13,4 @@
|
|||
17_check_smtp_fix_duplicate_cert_message.dpatch
|
||||
03_check_disk_smb_perfdata.dpatch
|
||||
18_check_snmp_labels.dpatch
|
||||
19_check_http_help.dpatch
|
||||
|
|
26
debian/patches/19_check_http_help.dpatch
vendored
Normal file
26
debian/patches/19_check_http_help.dpatch
vendored
Normal file
|
@ -0,0 +1,26 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 18_check_snmp_labels.dpatch
|
||||
## From d796c16327e6e315dd528f17e8bd597c5f506730 Mon Sep 17 00:00:00 2001
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Fri, 24 Feb 2012 13:24:56 +0100
|
||||
## Subject: [PATCH] Clarify that check_http won't verify certificates
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=patch;h=d796c16327e6e315dd528f17e8bd597c5f506730
|
||||
##
|
||||
## DP: check_http: clarify that check_http won't verify certificates (http://bugs.debian.org/644627)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_http.c
|
||||
+++ b/plugins/check_http.c
|
||||
@@ -1400,6 +1400,10 @@ print_help (void)
|
||||
printf (" %s\n", _("serve content (optionally within a specified time) or whether the X509 "));
|
||||
printf (" %s\n", _("certificate is still valid for the specified number of days."));
|
||||
printf ("\n");
|
||||
+ printf (" %s\n", _("Please note that this plugin does not check if the presented server"));
|
||||
+ printf (" %s\n", _("certificate matches the hostname of the server, or if the certificate"));
|
||||
+ printf (" %s\n", _("has a valid chain of trust to one of the locally installed CAs."));
|
||||
+ printf ("\n");
|
||||
printf ("%s\n", _("Examples:"));
|
||||
printf (" %s\n\n", "CHECK CONTENT: check_http -w 5 -c 10 --ssl -H www.verisign.com");
|
||||
printf (" %s\n", _("When the 'www.verisign.com' server returns its content within 5 seconds,"));
|
||||
|
Loading…
Reference in a new issue