crap, i never committed the changes for 1.5.1 even though i uploaded it.

"whoops" my bad.
This commit is contained in:
Sean Finney 2006-12-05 18:25:10 +00:00
parent 37cb311f16
commit 0ef129fa86
4 changed files with 35 additions and 23 deletions

14
debian/changelog vendored
View file

@ -1,8 +1,16 @@
nagios-plugins (1.4.4-3) UNRELEASED; urgency=low nagios-plugins (1.4.5-1) unstable; urgency=low
* NOT RELEASED YET * new upstream (bugfix only) release. the following patches
have been obsoleted:
- 27_is_hostname.dpatch
* fix for segfaulting check_radius plugin, thanks to Yasper
Casper for finding it (closes: #399532, #379788).
patch: 27_check_radius_segfault.dpatch
* regarding the fix for check_ups in the previous patch: both
the bug number and the attribution were incorrect. thanks are
due to Robbert Kouprie (closes: #398780).
-- sean finney <seanius@copelandia.seanius.net> Fri, 17 Nov 2006 09:42:43 +0100 -- sean finney <seanius@debian.org> Mon, 20 Nov 2006 20:31:23 +0100
nagios-plugins (1.4.4-2) unstable; urgency=low nagios-plugins (1.4.4-2) unstable; urgency=low

View file

@ -6,4 +6,4 @@
23_check_axis.dpatch 23_check_axis.dpatch
25_check_tcp-expect.dpatch 25_check_tcp-expect.dpatch
26_implicit-basename.dpatch 26_implicit-basename.dpatch
27_is_hostname.dpatch 27_check_radius_segfault.dpatch

View file

@ -0,0 +1,23 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 27_check_radius_segfault.dpatch by Yasper Casper <komputnik@gmail.com>
##
@DPATCH@
diff -urNad nagios-plugins-1.4.5~/plugins/check_radius.c nagios-plugins-1.4.5/plugins/check_radius.c
--- nagios-plugins-1.4.5~/plugins/check_radius.c 2006-10-20 01:53:28.000000000 +0200
+++ nagios-plugins-1.4.5/plugins/check_radius.c 2006-11-20 20:38:49.000000000 +0100
@@ -137,6 +137,14 @@
rc_read_dictionary (rc_conf_str (str)))
die (STATE_UNKNOWN, _("Config file error"));
+ /* Initialize Value Pair to prevent segfault on rc_avpair_add.
+ * debugging on radiuslib-ng show that the mem isn't allocated,
+ * and some random memory is in the USER-PASSWORD pair.
+ * So, after initialization, the password is filled with the correct values
+ */
+ data.send_pairs = NULL;
+ data.receive_pairs = NULL;
+
service = PW_AUTHENTICATE_ONLY;
if (!(rc_avpair_add (&data.send_pairs, PW_SERVICE_TYPE, &service, 0) &&

View file

@ -1,19 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 27_is_hostname.dpatch by <seanius@localhost.localdomain>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: No description.
@DPATCH@
diff -urNad nagios-plugins-1.4.4~/plugins-scripts/utils.pm.in nagios-plugins-1.4.4/plugins-scripts/utils.pm.in
--- nagios-plugins-1.4.4~/plugins-scripts/utils.pm.in 2006-10-19 20:44:53.000000000 +0200
+++ nagios-plugins-1.4.4/plugins-scripts/utils.pm.in 2006-11-17 09:36:05.000000000 +0100
@@ -76,7 +76,7 @@
sub is_hostname {
my $host1 = shift;
- if ($host1 && $host1 =~ m/^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+|[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)*)$/) {
+ if ($host1 && $host1 =~ m/^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+|[a-zA-Z0-9-]+(\.[a-zA-Z0-9-]+)*)$/) {
return 1;
}else{
return 0;