Add 14_check_icmp_multiple_ips.dpatch (Closes: #623702)
This commit is contained in:
parent
a9ca9d33bd
commit
116ac59bdb
11
debian/changelog
vendored
11
debian/changelog
vendored
|
@ -1,3 +1,14 @@
|
|||
nagios-plugins (1.4.15-3squeeze1) unstable; urgency=low
|
||||
|
||||
* Add 14_check_icmp_multiple_ips.dpatch (Closes: #623702), thanks Max Kosmach
|
||||
for spotting and Sebastian Harl for providing a fix
|
||||
- When specifying a host-name on the command line, each of its IPs is added
|
||||
to the host table (and each one is pinged). So, the buffer has to be large
|
||||
enough to hold all of the respective host objects. (argc - 1) only fits
|
||||
hosts with a single IP.
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Wed, 18 May 2011 21:21:05 +0200
|
||||
|
||||
nagios-plugins (1.4.15-3) unstable; urgency=low
|
||||
|
||||
* Add 10_check_disk_smb_spaces.dpatch from upstream svn (Closes: #601699),
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -5,3 +5,4 @@
|
|||
10_check_disk_smb_spaces.dpatch
|
||||
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
||||
12_check_snmp_1.4.15_regression.dpatch
|
||||
14_check_icmp_multiple_ips.dpatch
|
||||
|
|
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
|
@ -0,0 +1,27 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 14_check_icmp_multiple_ips.dpatch
|
||||
## Sebastian Harl <sh@teamix.net>
|
||||
##
|
||||
## From: 1374f80872412b64bd13f17e6edd70aa59437012 Mon Sep 17 00:00:00 2001
|
||||
## From: Sebastian Harl <sh@teamix.net>
|
||||
## Date: Thu, 28 Apr 2011 09:18:21 +0200
|
||||
## Subject: [PATCH] check_host: Allocate a large-enough buffer for the host table.
|
||||
## (Debian #623702)
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=1374f80872412b64bd13f17e6edd70aa59437012
|
||||
##
|
||||
## DP: Allocate a large-enough buffer for the host table. (http://bugs.debian.org/623702)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins-root/check_icmp.c
|
||||
+++ b/plugins-root/check_icmp.c
|
||||
@@ -621,7 +621,7 @@ main(int argc, char **argv)
|
||||
}
|
||||
|
||||
host = list;
|
||||
- table = malloc(sizeof(struct rta_host **) * (argc - 1));
|
||||
+ table = malloc(sizeof(struct rta_host **) * targets);
|
||||
i = 0;
|
||||
while(host) {
|
||||
host->id = i*packets;
|
||||
|
Loading…
Reference in a new issue