fix multiple labels
This commit is contained in:
parent
606f04878e
commit
117e9973f7
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -11,6 +11,8 @@ nagios-plugins (1.4.15-6) UNRELEASED; urgency=low
|
|||
* Add build-arch and build-indep targets to debian/rules
|
||||
* Add 03_check_disk_smb_perfdata.dpatch to add perfdata to check_disk_smb
|
||||
(Closes: #654259), thanks to G. Leimua
|
||||
* Add 04_check_snmp_labels.dpatch to fix multiple labels in check_snmp
|
||||
(Closes: #647020), thanks to Oskar Liljeblad
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Wed, 07 Sep 2011 15:33:55 +0200
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -1,5 +1,6 @@
|
|||
01_subst.in.dpatch
|
||||
02_check_icmp_links.dpatch
|
||||
04_check_snmp_labels.dpatch
|
||||
# commited upstream
|
||||
05_check_linux_raid_fix_striped.dpatch
|
||||
10_check_disk_smb_spaces.dpatch
|
||||
|
|
18
debian/patches/04_check_snmp_labels.dpatch
vendored
Executable file
18
debian/patches/04_check_snmp_labels.dpatch
vendored
Executable file
|
@ -0,0 +1,18 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 04_check_snmp_labels.dpatch by Oskar Liljeblad <oskar@osk.mine.nu>
|
||||
##
|
||||
## DP: check_snmp: fix multiple labels. (http://bugs.debian.org/647020)
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.15~/plugins/check_snmp.c nagios-plugins-1.4.15/plugins/check_snmp.c
|
||||
--- nagios-plugins-1.4.15~/plugins/check_snmp.c 2010-07-27 22:47:16.000000000 +0200
|
||||
+++ nagios-plugins-1.4.15/plugins/check_snmp.c 2012-02-24 01:08:16.000000000 +0100
|
||||
@@ -753,7 +753,7 @@
|
||||
if (labels == NULL)
|
||||
die (STATE_UNKNOWN, _("Could not reallocate labels\n"));
|
||||
}
|
||||
- labels++;
|
||||
+ nlabels++;
|
||||
ptr = thisarg (ptr);
|
||||
if (strstr (ptr, "'") == ptr)
|
||||
labels[nlabels - 1] = ptr + 1;
|
Loading…
Reference in a new issue