Revert "Add patch to fix FTBFS with MariaDB 10.3. (closes: #919375)"

This reverts commit 7fafae5386.
This commit is contained in:
Jan Wagner 2019-01-18 21:17:36 +01:00
parent 3fa4c45d8d
commit 15f2a2be74
3 changed files with 0 additions and 33 deletions

2
debian/changelog vendored
View file

@ -2,8 +2,6 @@ monitoring-plugins (2.2-5) UNRELEASED; urgency=medium
[ Bas Couwenberg ]
* Bump Standards-Version to 4.3.0, no changes.
* Add patch to fix FTBFS with MariaDB 10.3.
(closes: #919375)
[ Andreas Henriksson ]
* Pass PATH_TO_APTGET=/usr/bin/apt-get to configure

View file

@ -1,30 +0,0 @@
Description: Add support for MariaDB 10.3.
Author: Bas Couwenberg <sebastic@debian.org>
Bug-Debian: https://bugs.debian.org/919395
--- a/plugins/check_mysql.c
+++ b/plugins/check_mysql.c
@@ -45,6 +45,10 @@ const char *email = "devel@monitoring-pl
#include <mysqld_error.h>
#include <errmsg.h>
+#ifndef MYSQL_PORT
+#define MYSQL_PORT 3306
+#endif
+
char *db_user = NULL;
char *db_host = NULL;
char *db_socket = NULL;
--- a/plugins/check_mysql_query.c
+++ b/plugins/check_mysql_query.c
@@ -41,6 +41,10 @@ const char *email = "devel@monitoring-pl
#include <mysql.h>
#include <errmsg.h>
+#ifndef MYSQL_PORT
+#define MYSQL_PORT 3306
+#endif
+
char *db_user = NULL;
char *db_host = NULL;
char *db_socket = NULL;

View file

@ -4,4 +4,3 @@
11_check_dhcp_MSG_PEAK
12_check_apt_only_crit
13_check_apt_list_packages
mariadb-10.3.patch