fix some options help for check_ntp_peer and check_ntp_time
This commit is contained in:
parent
94058be412
commit
18ab211500
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -10,6 +10,8 @@ nagios-plugins (1.4.11-1) UNRELEASED; urgency=low
|
|||
together with libpq-dev (closes: #462509).
|
||||
* add 29_check_ntp_fixsefault_deprecate.dpatch to fix segfaults for
|
||||
check_ntp and check_ntp_time
|
||||
* add 30_fix_check_ntp_options.dpatch to fix options help for check_ntp_peer
|
||||
and check_ntp_time
|
||||
|
||||
-- Sean Finney <seanius@debian.org> Fri, 07 Dec 2007 01:01:17 +0100
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -7,4 +7,5 @@
|
|||
27_check_radius_segfault.dpatch
|
||||
28_check_pgsql_include_for_8.3.dpatch
|
||||
29_check_ntp_fixsefault_deprecate.dpatch
|
||||
30_fix_check_ntp_options.dpatch
|
||||
50_misc_typos.dpatch
|
||||
|
|
29
debian/patches/30_fix_check_ntp_options.dpatch
vendored
Normal file
29
debian/patches/30_fix_check_ntp_options.dpatch
vendored
Normal file
|
@ -0,0 +1,29 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 30_fix_check_ntp_options.dpatch by Jan Wagner <waja@cyconet.org>
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
## DP: Fix options for check_ntp_time and check_ntp_peer
|
||||
|
||||
@DPATCH@
|
||||
--- nagios-plugins-1.4.11/plugins/check_ntp_time.c.orig 2008-01-26 00:03:57.486086968 +0100
|
||||
+++ nagios-plugins-1.4.11/plugins/check_ntp_time.c 2008-01-26 00:04:26.652580066 +0100
|
||||
@@ -631,7 +631,6 @@
|
||||
print_usage(void)
|
||||
{
|
||||
printf (_("Usage:"));
|
||||
- printf(" %s -H <host> [-w <warn>] [-c <crit>] [-W <warn>] [-C <crit>]\n", progname);
|
||||
- printf(" [-j <warn>] [-k <crit>] [-v verbose]\n");
|
||||
+ printf(" %s -H <host> [-w <warn>] [-c <crit>] [-v verbose]\n", progname);
|
||||
}
|
||||
|
||||
--- nagios-plugins-1.4.11/plugins/check_ntp_peer.c.orig 2008-01-26 00:08:50.393996604 +0100
|
||||
+++ nagios-plugins-1.4.11/plugins/check_ntp_peer.c 2008-01-26 00:09:36.762190836 +0100
|
||||
@@ -642,7 +642,7 @@
|
||||
printf (" %s\n", _("Offset to result in critical status (seconds)"));
|
||||
printf (" %s\n", "-W, --warning=THRESHOLD");
|
||||
printf (" %s\n", _("Warning threshold for stratum"));
|
||||
- printf (" %s\n", "-W, --critical=THRESHOLD");
|
||||
+ printf (" %s\n", "-C, --critical=THRESHOLD");
|
||||
printf (" %s\n", _("Critical threshold for stratum"));
|
||||
printf (" %s\n", "-j, --warning=THRESHOLD");
|
||||
printf (" %s\n", _("Warning threshold for jitter"));
|
Loading…
Reference in a new issue