check_tcp fix
This commit is contained in:
parent
395ff43598
commit
2d4b037705
4
debian/changelog
vendored
4
debian/changelog
vendored
|
@ -9,8 +9,10 @@ nagios-plugins (1.4.4-1) unstable; urgency=low
|
||||||
from nagios-plugins to nagios-plugins-foo, so we're now managing
|
from nagios-plugins to nagios-plugins-foo, so we're now managing
|
||||||
all the config files via ucf (closes: #339971).
|
all the config files via ucf (closes: #339971).
|
||||||
* remove some unneeded build-deps, and bump Standards-Version
|
* remove some unneeded build-deps, and bump Standards-Version
|
||||||
|
* fix for multiple expect strings in check_tcp.c. thanks to Ralph Rößner
|
||||||
|
for finding this (closes: #395176).
|
||||||
|
|
||||||
-- sean finney <seanius@debian.org> Sat, 02 Sep 2006 23:03:45 +0200
|
-- sean finney <seanius@debian.org> Wed, 01 Nov 2006 22:28:14 +0100
|
||||||
|
|
||||||
nagios-plugins (1.4.3.0cvs.20060707-3) unstable; urgency=high
|
nagios-plugins (1.4.3.0cvs.20060707-3) unstable; urgency=high
|
||||||
|
|
||||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -5,3 +5,4 @@
|
||||||
22_check_smb_hostaddress.dpatch
|
22_check_smb_hostaddress.dpatch
|
||||||
23_check_axis.dpatch
|
23_check_axis.dpatch
|
||||||
24_check_ups.dpatch
|
24_check_ups.dpatch
|
||||||
|
25_check_tcp-expect.dpatch
|
||||||
|
|
18
debian/patches/25_check_tcp-expect.dpatch
vendored
Executable file
18
debian/patches/25_check_tcp-expect.dpatch
vendored
Executable file
|
@ -0,0 +1,18 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 25_check_tcp-expect.dpatch by <seanius@debian.org>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: No description.
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -urNad nagios-plugins-1.4.4~/plugins/check_tcp.c nagios-plugins-1.4.4/plugins/check_tcp.c
|
||||||
|
--- nagios-plugins-1.4.4~/plugins/check_tcp.c 2006-09-02 22:32:27.000000000 +0200
|
||||||
|
+++ nagios-plugins-1.4.4/plugins/check_tcp.c 2006-11-01 22:20:43.000000000 +0100
|
||||||
|
@@ -494,7 +494,6 @@
|
||||||
|
asprintf(&server_send, "%s", optarg);
|
||||||
|
break;
|
||||||
|
case 'e': /* expect string (may be repeated) */
|
||||||
|
- EXPECT = NULL;
|
||||||
|
flags &= ~FLAG_EXACT_MATCH;
|
||||||
|
if (server_expect_count == 0)
|
||||||
|
server_expect = malloc (sizeof (char *) * (++server_expect_count));
|
Loading…
Reference in a new issue