fix processing via embedded perl of check_disk_smb
This commit is contained in:
parent
b02868c0c9
commit
31be3d3d44
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -24,6 +24,8 @@ nagios-plugins (1.4.12-1) UNRELEASED; urgency=low
|
|||
* include list of files which are GPL3 into copyright
|
||||
* build depend on libradiusclient-ng-dev instead of libradius1-dev (for more
|
||||
informations see REQUIREMENTS)
|
||||
* add 33_fix_emb_check_disk_smb.dpatch which fixes processing via embedded
|
||||
perl of check_disk_smb (Closes: #478906)
|
||||
|
||||
[ Alexander Wirt ]
|
||||
* Call smbclient with -N (supress password prompt) if no password is
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -7,4 +7,5 @@
|
|||
26_implicit-basename.dpatch
|
||||
27_check_radius_segfault.dpatch
|
||||
32_check_ldap_pointer.dpatch
|
||||
33_fix_emb_check_disk_smb.dpatch
|
||||
50_misc_typos.dpatch
|
||||
|
|
44
debian/patches/33_fix_emb_check_disk_smb.dpatch
vendored
Normal file
44
debian/patches/33_fix_emb_check_disk_smb.dpatch
vendored
Normal file
|
@ -0,0 +1,44 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 32_check_ldap_pointer.dpatch by Jan Wagner <waja@cyconet.org>
|
||||
## patch provided by Stephane Chazelas <stephane@artesyncp.com>
|
||||
##
|
||||
## DP: fix processing vi embedded perl interpreter
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-1.4.12~/plugins-scripts/check_disk_smb.pl nagios-plugins-1.4.12/plugins-scripts/check_disk_smb.pl
|
||||
--- nagios-plugins-1.4.12~/plugins-scripts/check_disk_smb.pl 2008-06-06 11:57:33.000000000 +0200
|
||||
+++ nagios-plugins-1.4.12/plugins-scripts/check_disk_smb.pl 2008-06-06 11:58:03.000000000 +0200
|
||||
@@ -65,27 +65,27 @@
|
||||
|
||||
# Options checking
|
||||
|
||||
-($opt_H) || ($opt_H = shift) || usage("Host name not specified\n");
|
||||
+($opt_H) || ($opt_H = shift @ARGV) || usage("Host name not specified\n");
|
||||
my $host = $1 if ($opt_H =~ /^([-_.A-Za-z0-9 ]+\$?)$/);
|
||||
($host) || usage("Invalid host: $opt_H\n");
|
||||
|
||||
-($opt_s) || ($opt_s = shift) || usage("Share volume not specified\n");
|
||||
+($opt_s) || ($opt_s = shift @ARGV) || usage("Share volume not specified\n");
|
||||
my $share = $1 if ($opt_s =~ /^([-_.A-Za-z0-9]+\$?)$/);
|
||||
($share) || usage("Invalid share: $opt_s\n");
|
||||
|
||||
-($opt_u) || ($opt_u = shift) || ($opt_u = "guest");
|
||||
+($opt_u) || ($opt_u = shift @ARGV) || ($opt_u = "guest");
|
||||
my $user = $1 if ($opt_u =~ /^([-_.A-Za-z0-9\\]+)$/);
|
||||
($user) || usage("Invalid user: $opt_u\n");
|
||||
|
||||
-($opt_p) || ($opt_p = shift) || ($opt_p = "");
|
||||
+($opt_p) || ($opt_p = shift @ARGV) || ($opt_p = "");
|
||||
my $pass = $1 if ($opt_p =~ /(.*)/);
|
||||
$pass = "-N" if ($opt_p eq "");
|
||||
|
||||
-($opt_w) || ($opt_w = shift) || ($opt_w = 85);
|
||||
+($opt_w) || ($opt_w = shift @ARGV) || ($opt_w = 85);
|
||||
my $warn = $1 if ($opt_w =~ /^([0-9]{1,2}\%?|100\%?|[0-9]+[kMG])$/);
|
||||
($warn) || usage("Invalid warning threshold: $opt_w\n");
|
||||
|
||||
-($opt_c) || ($opt_c = shift) || ($opt_c = 95);
|
||||
+($opt_c) || ($opt_c = shift @ARGV) || ($opt_c = 95);
|
||||
my $crit = $1 if ($opt_c =~ /^([0-9]{1,2}\%?|100\%?|[0-9]+[kMG])$/);
|
||||
($crit) || usage("Invalid critical threshold: $opt_c\n");
|
||||
|
Loading…
Reference in a new issue