drop 23_check_smb_password.dpatch

This commit is contained in:
Jan Wagner 2010-04-11 19:25:23 +00:00
parent ebac29e6a0
commit 3d271b079b
3 changed files with 1 additions and 19 deletions

2
debian/changelog vendored
View file

@ -10,7 +10,7 @@ nagios-plugins (1.4.14-5) UNRELEASED; urgency=low
the patch
* Drop 13_subst.in_again.dpatch and move 38_fix_libexec.dpatch to
13_subst.in_again.dpatch
* Fix 34_fix_smbclient_check_disk_smb.dpatch from reverting changes from
* Fix 34_fix_smbclient_check_disk_smb.dpatch and drop
23_check_smb_password.dpatch, thanks Holger Weiss for notification
-- Jan Wagner <waja@cyconet.org> Thu, 08 Apr 2010 23:54:05 +0200

View file

@ -3,7 +3,6 @@
13_subst.in_again.dpatch
18_check_game_cmdline.dpatch
22_check_smb_hostaddress.dpatch
23_check_smb_password.dpatch
32_check_ldap_pointer.dpatch
33_fix_emb_check_disk_smb.dpatch
34_fix_smbclient_check_disk_smb.dpatch

View file

@ -1,17 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 23_check_smb_password.dpatch by Alexander Wirt <formorer@debian.org>
##
## DP: If there is no password set call smbclient with -N (suppress password prompt, bugs.debian.org/425129)
@DPATCH@
diff -urNad nagios-plugins-1.4.11~/plugins-scripts/check_disk_smb.pl nagios-plugins-1.4.11/plugins-scripts/check_disk_smb.pl
--- nagios-plugins-1.4.11~/plugins-scripts/check_disk_smb.pl 2008-05-02 07:13:08.000000000 +0200
+++ nagios-plugins-1.4.11/plugins-scripts/check_disk_smb.pl 2008-05-02 07:15:23.000000000 +0200
@@ -79,6 +79,7 @@
($opt_p) || ($opt_p = shift) || ($opt_p = "");
my $pass = $1 if ($opt_p =~ /(.*)/);
+$pass = "-N" if ($opt_p eq "");
($opt_w) || ($opt_w = shift) || ($opt_w = 85);
my $warn = $1 if ($opt_w =~ /^([0-9]{1,2}\%?|100\%?|[0-9]+[kMG])$/);