drop more patches

This commit is contained in:
Jan Wagner 2008-06-03 11:49:05 +00:00
parent 9ae19105a9
commit 421caf516c
6 changed files with 1 additions and 144 deletions

1
debian/changelog vendored
View file

@ -3,6 +3,7 @@ nagios-plugins (1.4.12-1) UNRELEASED; urgency=low
[ Jan Wagner ] [ Jan Wagner ]
* new upstream * new upstream
* removed the following patches, cause fixed upstream * removed the following patches, cause fixed upstream
- 28_check_pgsql_include_for_8.3.dpatch
- 29_check_ntp_fixsefault_deprecate.dpatch - 29_check_ntp_fixsefault_deprecate.dpatch
- 30_fix_check_ntp_options.dpatch - 30_fix_check_ntp_options.dpatch
- 31_check_disk_local_option.dpatch - 31_check_disk_local_option.dpatch

View file

@ -6,6 +6,5 @@
23_check_smb_password.dpatch 23_check_smb_password.dpatch
26_implicit-basename.dpatch 26_implicit-basename.dpatch
27_check_radius_segfault.dpatch 27_check_radius_segfault.dpatch
28_check_pgsql_include_for_8.3.dpatch
32_check_ldap_pointer.dpatch 32_check_ldap_pointer.dpatch
50_misc_typos.dpatch 50_misc_typos.dpatch

View file

@ -1,17 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 28_check_pgsql_include_for_8.3.dpatch by Jan Wagner <waja@cyconet.org>
##
## DP: include pg_config_manual.h since NAMEDATALEN definition moved there with psql 8.3
@DPATCH@
diff -Nur nagios-plugins-1.4.11.orig/plugins/check_pgsql.c nagios-plugins-1.4.11/plugins/check_pgsql.c
--- nagios-plugins-1.4.11.orig/plugins/check_pgsql.c 2007-01-28 22:46:41.000000000 +0100
+++ nagios-plugins-1.4.11/plugins/check_pgsql.c 2008-01-24 15:54:56.533368467 +0100
@@ -43,6 +43,7 @@
#include "utils.h"
#include "netutils.h"
+#include "pg_config_manual.h"
#include <libpq-fe.h>
#define DEFAULT_DB "template1"

View file

@ -1,80 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 29_check_ntp_fixsefault_deprecate.dpatch by Thomas Guyot-Sionnest <dermoth@aei.ca>
##
## DP: Fix check_ntp_time and check_ntp segfault, add deprecate hints
@DPATCH@
--- nagios-plugins-1.4.11/plugins/check_ntp_time.c 2007/12/11 05:57:35 1861
+++ nagios-plugins-1.4.11/plugins/check_ntp_time.c 2008/01/05 14:09:29 1887
@@ -274,7 +274,7 @@
/* if we haven't reached the current list's end, move everyone
* over one to the right, and insert the new candidate */
if(i<csize){
- for(j=5; j>i; j--){
+ for(j=4; j>i; j--){
candidates[j]=candidates[j-1];
}
}
@@ -337,6 +337,7 @@
servers=(ntp_server_results*)malloc(sizeof(ntp_server_results)*num_hosts);
if(servers==NULL) die(STATE_UNKNOWN, "can not allocate server array");
memset(servers, 0, sizeof(ntp_server_results)*num_hosts);
+ DBG(printf("Found %d peers to check\n", num_hosts));
/* setup each socket for writing, and the corresponding struct pollfd */
ai_tmp=ai;
--- nagios-plugins-1.4.11/plugins/check_ntp.c 2007/12/11 05:57:35 1861
+++ nagios-plugins-1.4.11/plugins/check_ntp.c 2008/01/05 14:09:29 1887
@@ -329,7 +329,7 @@
/* if we haven't reached the current list's end, move everyone
* over one to the right, and insert the new candidate */
if(i<csize){
- for(j=5; j>i; j--){
+ for(j=4; j>i; j--){
candidates[j]=candidates[j-1];
}
}
@@ -392,6 +392,7 @@
servers=(ntp_server_results*)malloc(sizeof(ntp_server_results)*num_hosts);
if(servers==NULL) die(STATE_UNKNOWN, "can not allocate server array");
memset(servers, 0, sizeof(ntp_server_results)*num_hosts);
+ DBG(printf("Found %d peers to check\n", num_hosts));
/* setup each socket for writing, and the corresponding struct pollfd */
ai_tmp=ai;
@@ -837,11 +838,11 @@
printf ("Copyright (c) 2006 Sean Finney\n");
printf (COPYRIGHT, copyright, email);
-
- printf ("%s\n", _("This plugin checks the selected ntp server"));
- printf ("\n\n");
-
+ printf ("%s\n", _("This plugin checks the selected ntp server"));
+
+ printf ("\n\n");
+
print_usage();
printf (_(UT_HELP_VRSN));
printf (_(UT_HOST_PORT), 'p', "123");
@@ -871,11 +872,17 @@
printf(" %s\n", ("./check_ntp -H ntpserv -w 0.5 -c 1 -j -1:100 -k -1:200"));
printf (_(UT_SUPPORT));
+
+ printf("\n");
+ printf ("%s\n", _("WARNING: check_ntp is deprecated. Please use check_ntp_peer or"));
+ printf ("%s\n\n", _("check_ntp_time istead."));
}
void
print_usage(void)
{
- printf (_("Usage:"));
- printf(" %s -H <host> [-w <warn>] [-c <crit>] [-j <warn>] [-k <crit>] [-v verbose]\n", progname);
+ printf ("%s\n", _("WARNING: check_ntp is deprecated. Please use check_ntp_peer or"));
+ printf ("%s\n\n", _("check_ntp_time istead."));
+ printf (_("Usage:"));
+ printf(" %s -H <host> [-w <warn>] [-c <crit>] [-j <warn>] [-k <crit>] [-v verbose]\n", progname);
}

View file

@ -1,28 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 30_fix_check_ntp_options.dpatch by Jan Wagner <waja@cyconet.org>
##
## DP: Fix options for check_ntp_time and check_ntp_peer
@DPATCH@
--- nagios-plugins-1.4.11/plugins/check_ntp_time.c.orig 2008-01-26 00:03:57.486086968 +0100
+++ nagios-plugins-1.4.11/plugins/check_ntp_time.c 2008-01-26 00:04:26.652580066 +0100
@@ -631,7 +631,6 @@
print_usage(void)
{
printf (_("Usage:"));
- printf(" %s -H <host> [-w <warn>] [-c <crit>] [-W <warn>] [-C <crit>]\n", progname);
- printf(" [-j <warn>] [-k <crit>] [-v verbose]\n");
+ printf(" %s -H <host> [-w <warn>] [-c <crit>] [-v verbose]\n", progname);
}
--- nagios-plugins-1.4.11/plugins/check_ntp_peer.c.orig 2008-01-26 00:08:50.393996604 +0100
+++ nagios-plugins-1.4.11/plugins/check_ntp_peer.c 2008-01-26 00:09:36.762190836 +0100
@@ -642,7 +642,7 @@
printf (" %s\n", _("Offset to result in critical status (seconds)"));
printf (" %s\n", "-W, --warning=THRESHOLD");
printf (" %s\n", _("Warning threshold for stratum"));
- printf (" %s\n", "-W, --critical=THRESHOLD");
+ printf (" %s\n", "-C, --critical=THRESHOLD");
printf (" %s\n", _("Critical threshold for stratum"));
printf (" %s\n", "-j, --warning=THRESHOLD");
printf (" %s\n", _("Warning threshold for jitter"));

View file

@ -1,18 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 31_check_disk_local_option.dpatch by Jan Wagner <waja@cyconet.org>
##
## DP: Fix local option for check_disk
@DPATCH@
diff -Nur nagios-plugins-1.4.11/plugins/check_disk.c.orig nagios-plugins-1.4.11/plugins/check_disk.c
--- nagios-plugins-1.4.11/plugins/check_disk.c.orig 2007-12-08 17:34:05.000000000 +0100
+++ nagios-plugins-1.4.11/plugins/check_disk.c 2008-02-05 22:13:43.397159697 +0100
@@ -475,7 +475,7 @@
{"iwarning", required_argument, 0, 'W'},
/* Dang, -C is taken. We might want to reshuffle this. */
{"icritical", required_argument, 0, 'K'},
- {"local", required_argument, 0, 'l'},
+ {"local", no_argument, 0, 'l'},
{"stat-remote-fs", required_argument, 0, 'L'},
{"kilobytes", required_argument, 0, 'k'},
{"megabytes", required_argument, 0, 'm'},