depend on inetutils-ping

This commit is contained in:
Jan Wagner 2009-12-05 01:51:36 +00:00
parent ab3ba9033c
commit 466c887bee
5 changed files with 46 additions and 4 deletions

7
debian/changelog vendored
View file

@ -18,8 +18,13 @@ nagios-plugins (1.4.14-1) unstable; urgency=low
* Add 40_check_http_proxy_auth.dpatch to make check_http able to check proxy
authorization
* Update copyright, thanks to Robert Millan (Closes: 548303)
* Depend on inetutils-ping instead of iputils-ping, thanks to Petr Salinger
(Closes: #555532)
- Use '-n -c %d %s' as ping argument, since unfortunately '-U -w %d' isn't
supported by inetutils-ping
- Add 41_check_ping_detect_args.dpatch, that to Thomas Guyot-Sionnest
-- Jan Wagner <waja@cyconet.org> Thu, 12 Nov 2009 02:19:28 +0100
-- Jan Wagner <waja@cyconet.org> Sat, 05 Dec 2009 02:46:35 +0100
nagios-plugins (1.4.13+git200906171200-1) unstable; urgency=low

2
debian/control vendored
View file

@ -33,7 +33,7 @@ Description: Plugins for the nagios network monitoring and management system
Package: nagios-plugins-basic
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, procps, iputils-ping, ucf
Depends: ${shlibs:Depends}, ${misc:Depends}, procps, inetutils-ping, ucf
Conflicts: nagios-plugins (<= 1.4.2-3)
Replaces: nagios-plugins, nagios-plugins-standard
Suggests: nagios3

View file

@ -15,3 +15,4 @@
38_fix_libexec.dpatch
39_check_ircd_fix_epn.dpatch
40_check_http_proxy_auth.dpatch
41_check_ping_detect_args.dpatch

View file

@ -0,0 +1,36 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 41_check_ping_detect_args.dpatch
## From: Thomas Guyot-Sionnest <dermoth@aei.ca>
## Date: Fri, 4 Dec 2009 15:24:15 -0500
## Subject: [PATCH] Detect arguments passed via --with-ping[6]-command (#2908236)
### X-Git-Url: http://repo.or.cz/w/nagiosplugins.git?a=commitdiff_plain;h=08199792ba8bf19c2dbdc27f68689e571d4240a9
##
## DP: Detect arguments passed via --with-ping[6]-command (SF #2908236 / Debian #555532)
@DPATCH@
diff --git a/configure.in b/configure.in
index f354734..84b2050 100644
--- a/configure.in
+++ b/configure.in
@@ -877,10 +877,16 @@ ac_cv_ping_has_timeout=no
if test -n "$with_ping_command"
then
AC_MSG_RESULT([(command-line) $with_ping_command])
- if test -n "$ac_cv_ping_packets_first"
+ if echo "$with_ping_command" | grep '%d.*%d.*%s' >/dev/null
then
ac_cv_ping_packets_first=yes
ac_cv_ping_has_timeout=yes
+ elif echo "$with_ping_command" | grep '%d.*%s.*%d' >/dev/null
+ then
+ ac_cv_ping_has_timeout=yes
+ elif echo "$with_ping_command" | grep '%d.*%s' >/dev/null
+ then
+ ac_cv_ping_packets_first=yes
fi
elif [[ "z$ac_cv_uname_s" = "zUnixWare" ]] && \
--
1.6.5.1

4
debian/rules vendored
View file

@ -81,8 +81,8 @@ config.status: configure
--with-ps-format="%s %d %d %d %d %d %f %s %s %n" \
--with-ps-cols=10 \
--with-ps-varlist="procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procetime,procprog,&pos" \
--with-ping-command="/bin/ping -n -U -w %d -c %d %s" \
--with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" \
--with-ping-comman="/bin/ping -n -c %d %s" \
--with-ping6-command="/bin/ping6 -n -c %d %s" \
--with-nslookup-command="/usr/bin/nslookup -sil" \
--with-uptime-command="/usr/bin/uptime" \
--with-rpcinfo-command="/usr/bin/rpcinfo" \