fix epn in check_ircd
This commit is contained in:
parent
ca127377d5
commit
47e1f21829
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -9,6 +9,8 @@ nagios-plugins (1.4.13+git200906171200-2) UNRELEASED; urgency=low
|
|||
* Updating standards version to 3.8.3
|
||||
- Add README.source
|
||||
* droped unused patches from debian/patches
|
||||
* add 39_check_ircd_fix_epn.dpatch to fix epn, thanks to Hendrik Jaeger and
|
||||
Alexander Wirt (Closes: #545940)
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Thu, 06 Aug 2009 00:11:51 +0200
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -13,3 +13,4 @@
|
|||
36_check_ldap_empty_base.dpatch
|
||||
37_check_radius_nas-ip-address.dpatch
|
||||
38_fix_libexec.dpatch
|
||||
39_check_ircd_fix_epn.dpatch
|
||||
|
|
33
debian/patches/39_check_ircd_fix_epn.dpatch
vendored
Normal file
33
debian/patches/39_check_ircd_fix_epn.dpatch
vendored
Normal file
|
@ -0,0 +1,33 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 39_check_ircd_fix_epn.dpatch by Alexander Wirt <formorer@formorer.de>
|
||||
##
|
||||
## DP: Fixes epn in check_ircd (#545940)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- nagios-plugins-1.4.12~/plugins-scripts/check_ircd.pl 2009-08-23 09:40:38.000000000 +0200
|
||||
+++ nagios-plugins-1.4.12/plugins-scripts/check_ircd.pl 2009-09-22 23:35:52.000000000 +0200
|
||||
@@ -194,19 +194,19 @@
|
||||
|
||||
if ($opt_h) {print_help(); exit $ERRORS{'OK'};}
|
||||
|
||||
- ($opt_H) || ($opt_H = shift) || usage("Host name/address not specified\n");
|
||||
+ ($opt_H) || usage("Host name/address not specified\n");
|
||||
my $remotehost = $1 if ($opt_H =~ /([-.A-Za-z0-9]+)/);
|
||||
($remotehost) || usage("Invalid host: $opt_H\n");
|
||||
|
||||
- ($opt_w) || ($opt_w = shift) || ($opt_w = 50);
|
||||
+ ($opt_w) || ($opt_w = 50);
|
||||
my $warn = $1 if ($opt_w =~ /^([0-9]+)$/);
|
||||
($warn) || usage("Invalid warning threshold: $opt_w\n");
|
||||
|
||||
- ($opt_c) || ($opt_c = shift) || ($opt_c = 100);
|
||||
+ ($opt_c) || ($opt_c = 100);
|
||||
my $crit = $1 if ($opt_c =~ /^([0-9]+)$/);
|
||||
($crit) || usage("Invalid critical threshold: $opt_c\n");
|
||||
|
||||
- ($opt_p) || ($opt_p = shift) || ($opt_p = 6667);
|
||||
+ ($opt_p) || ($opt_p = 6667);
|
||||
my $remoteport = $1 if ($opt_p =~ /^([0-9]+)$/);
|
||||
($remoteport) || usage("Invalid port: $opt_p\n");
|
||||
|
Loading…
Reference in a new issue