update for new upstream release + typo fix
This commit is contained in:
parent
86dc2c445b
commit
48e18b390b
7
debian/changelog
vendored
7
debian/changelog
vendored
|
@ -1,8 +1,13 @@
|
||||||
nagios-plugins (1.4.10-2) UNRELEASED; urgency=low
|
nagios-plugins (1.4.11-1) UNRELEASED; urgency=low
|
||||||
|
|
||||||
[ Jan Wagner ]
|
[ Jan Wagner ]
|
||||||
|
* new upstream release
|
||||||
|
* drop CVE-2007-5623.dpatch since it's included upstream
|
||||||
* fix Vcs- fields fields
|
* fix Vcs- fields fields
|
||||||
* use $HOSTADDRESS$ instead of $HOSTNAME$ in dns.cfg (closes: #405244).
|
* use $HOSTADDRESS$ instead of $HOSTNAME$ in dns.cfg (closes: #405244).
|
||||||
|
* add typo fix for check_mailq into 50_misc_typos.dpatch (closes: #435525).
|
||||||
|
* add 28_check_pgsql_include_for_8.3.dpatch to get check_pgsql working
|
||||||
|
together with libpq-dev
|
||||||
|
|
||||||
-- Sean Finney <seanius@debian.org> Fri, 07 Dec 2007 01:01:17 +0100
|
-- Sean Finney <seanius@debian.org> Fri, 07 Dec 2007 01:01:17 +0100
|
||||||
|
|
||||||
|
|
2
debian/patches/00list
vendored
2
debian/patches/00list
vendored
|
@ -5,5 +5,5 @@
|
||||||
22_check_smb_hostaddress.dpatch
|
22_check_smb_hostaddress.dpatch
|
||||||
26_implicit-basename.dpatch
|
26_implicit-basename.dpatch
|
||||||
27_check_radius_segfault.dpatch
|
27_check_radius_segfault.dpatch
|
||||||
CVE-2007-5623.dpatch
|
28_check_pgsql_include_for_8.3.dpatch
|
||||||
50_misc_typos.dpatch
|
50_misc_typos.dpatch
|
||||||
|
|
18
debian/patches/28_check_pgsql_include_for_8.3.dpatch
vendored
Normal file
18
debian/patches/28_check_pgsql_include_for_8.3.dpatch
vendored
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 28_check_pgsql_include_for_8.3.dpatch by Jan Wagner <waja@cyconet.org>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: include pg_config_manual.h since NAMEDATALEN definition moved there with psql 8.3
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -Nur nagios-plugins-1.4.11.orig/plugins/check_pgsql.c nagios-plugins-1.4.11/plugins/check_pgsql.c
|
||||||
|
--- nagios-plugins-1.4.11.orig/plugins/check_pgsql.c 2007-01-28 22:46:41.000000000 +0100
|
||||||
|
+++ nagios-plugins-1.4.11/plugins/check_pgsql.c 2008-01-24 15:54:56.533368467 +0100
|
||||||
|
@@ -43,6 +43,7 @@
|
||||||
|
#include "utils.h"
|
||||||
|
|
||||||
|
#include "netutils.h"
|
||||||
|
+#include "pg_config_manual.h"
|
||||||
|
#include <libpq-fe.h>
|
||||||
|
|
||||||
|
#define DEFAULT_DB "template1"
|
12
debian/patches/50_misc_typos.dpatch
vendored
12
debian/patches/50_misc_typos.dpatch
vendored
|
@ -218,3 +218,15 @@ diff -Nur nagios-plugins-1.4.10.orig/plugins/check_ups.c nagios-plugins-1.4.10/p
|
||||||
printf ("%s\n", _("Smart UPS Tools be installed on the remote host. If you do not have the"));
|
printf ("%s\n", _("Smart UPS Tools be installed on the remote host. If you do not have the"));
|
||||||
printf ("%s\n", _("package installed on your system, you can download it from http://www.networkupstools.org"));
|
printf ("%s\n", _("package installed on your system, you can download it from http://www.networkupstools.org"));
|
||||||
|
|
||||||
|
diff -Nur nagios-plugins-1.4.10.orig/plugins-scripts/check_mailq.pl nagios-plugins-1.4.10/plugins-scripts/check_mailq.pl
|
||||||
|
--- nagios-plugins-1.4.10.orig/plugins-scripts/check_mailq.pl 2006-07-05 15:45:57.000000000 +0200
|
||||||
|
+++ nagios-plugins-1.4.10/plugins-scripts/check_mailq.pl 2007-12-10 01:18:51.803913108 +0100
|
||||||
|
@@ -588,7 +588,7 @@
|
||||||
|
print " Checks the number of messages in the mail queue (supports multiple sendmail queues, qmail)\n";
|
||||||
|
print " Feedback/patches to support non-sendmail mailqueue welcome\n\n";
|
||||||
|
print "-w (--warning) = Min. number of messages in queue to generate warning\n";
|
||||||
|
- print "-c (--critical) = Min. number of messages in queu to generate critical alert ( w < c )\n";
|
||||||
|
+ print "-c (--critical) = Min. number of messages in queue to generate critical alert ( w < c )\n";
|
||||||
|
print "-W (--Warning) = Min. number of messages for same domain in queue to generate warning\n";
|
||||||
|
print "-C (--Critical) = Min. number of messages for same domain in queue to generate critical alert ( W < C )\n";
|
||||||
|
print "-t (--timeout) = Plugin timeout in seconds (default = $utils::TIMEOUT)\n";
|
||||||
|
|
45
debian/patches/CVE-2007-5623.dpatch
vendored
45
debian/patches/CVE-2007-5623.dpatch
vendored
|
@ -1,45 +0,0 @@
|
||||||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
|
||||||
## CVE-2007-5623.dpatch by Nico Golde <nion@debian.org>
|
|
||||||
##
|
|
||||||
## All lines beginning with `## DP:' are a description of the patch.
|
|
||||||
## DP: No description.
|
|
||||||
|
|
||||||
@DPATCH@
|
|
||||||
diff -urNad nagios-plugins-1.4.8~/plugins/check_snmp.c nagios-plugins-1.4.8/plugins/check_snmp.c
|
|
||||||
--- nagios-plugins-1.4.8~/plugins/check_snmp.c 2007-02-02 10:10:22.000000000 +0100
|
|
||||||
+++ nagios-plugins-1.4.8/plugins/check_snmp.c 2007-10-28 16:14:48.000000000 +0100
|
|
||||||
@@ -217,12 +217,16 @@
|
|
||||||
|
|
||||||
ptr = output;
|
|
||||||
|
|
||||||
- strcat(perfstr, "| ");
|
|
||||||
+ strncat(perfstr, "| ", sizeof(perfstr)-strlen(perfstr)-1);
|
|
||||||
while (ptr) {
|
|
||||||
char *foo;
|
|
||||||
+ unsigned int copylen;
|
|
||||||
|
|
||||||
foo = strstr (ptr, delimiter);
|
|
||||||
- strncat(perfstr, ptr, foo-ptr);
|
|
||||||
+ copylen = foo-ptr;
|
|
||||||
+ if (copylen > sizeof(perfstr)-strlen(perfstr)-1)
|
|
||||||
+ copylen = sizeof(perfstr)-strlen(perfstr)-1;
|
|
||||||
+ strncat(perfstr, ptr, copylen);
|
|
||||||
ptr = foo;
|
|
||||||
|
|
||||||
if (ptr == NULL)
|
|
||||||
@@ -351,11 +355,11 @@
|
|
||||||
|
|
||||||
i++;
|
|
||||||
|
|
||||||
- strcat(perfstr, "=");
|
|
||||||
- strcat(perfstr, show);
|
|
||||||
+ strncat(perfstr, "=", sizeof(perfstr)-strlen(perfstr)-1);
|
|
||||||
+ strncat(perfstr, show, sizeof(perfstr)-strlen(perfstr)-1);
|
|
||||||
if (type)
|
|
||||||
- strcat(perfstr, type);
|
|
||||||
- strcat(perfstr, " ");
|
|
||||||
+ strncat(perfstr, type, sizeof(perfstr)-strlen(perfstr)-1);
|
|
||||||
+ strncat(perfstr, " ", sizeof(perfstr)-strlen(perfstr)-1);
|
|
||||||
|
|
||||||
} /* end while (ptr) */
|
|
||||||
|
|
Loading…
Reference in a new issue