Fix error in check_radius when compiling with -Werror=format-security
This commit is contained in:
parent
d91bc94fc4
commit
4a3a0d53c6
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -6,6 +6,8 @@ nagios-plugins (1.4.15-5) UNRELEASED; urgency=low
|
|||
Mitterer
|
||||
- Listing the checks of each package
|
||||
- Hint added, that nagios-plugins-basic needs more packages (recommands)
|
||||
* Fix error in check_radius when compiling with -Werror=format-security
|
||||
(hardening), thanks Thomas Guyot-Sionnesti - LP: #837085
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Wed, 18 May 2011 16:55:55 +0200
|
||||
|
||||
|
|
2
debian/patches/00list
vendored
2
debian/patches/00list
vendored
|
@ -7,3 +7,5 @@
|
|||
12_check_snmp_1.4.15_regression.dpatch
|
||||
13_check_smtp_greeting.dpatch
|
||||
14_check_icmp_multiple_ips.dpatch
|
||||
# 15_check_sensors_fault.dpatch
|
||||
16_check_raduis_fix_format-security.dpatch
|
||||
|
|
24
debian/patches/16_check_raduis_fix_format-security.dpatch
vendored
Normal file
24
debian/patches/16_check_raduis_fix_format-security.dpatch
vendored
Normal file
|
@ -0,0 +1,24 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 16_check_raduis_fix_format-security.dpatch
|
||||
## From 055b2570eddff9a312dc1445bb7de4a6d7c4887d Mon Sep 17 00:00:00 2001
|
||||
## From: Thomas Guyot-Sionnest <dermoth@aei.ca>
|
||||
## Date: Tue, 6 Sep 2011 23:20:21 -0400
|
||||
## Subject: [PATCH] Make GCC happy
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=055b2570eddff9a312dc1445bb7de4a6d7c4887d
|
||||
##
|
||||
## DP: It won't trust us about msg containing no format string, and fail miserably
|
||||
## when compiled with -Werror=format-security. (https://bugs.launchpad.net/bugs/837085)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_radius.c
|
||||
+++ b/plugins/check_radius.c
|
||||
@@ -211,7 +211,7 @@ main (int argc, char **argv)
|
||||
if (result == OK_RC)
|
||||
die (STATE_OK, _("Auth OK"));
|
||||
(void)snprintf(msg, sizeof(msg), _("Unexpected result code %d"), result);
|
||||
- die (STATE_UNKNOWN, msg);
|
||||
+ die (STATE_UNKNOWN, "%s", msg);
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue