fix return of check_jabber
This commit is contained in:
parent
2e3c362a88
commit
4c54273558
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -13,6 +13,8 @@ nagios-plugins (1.4.5-3) UNRELEASED; urgency=low
|
||||||
* remove static community string in ifstatus.cfg
|
* remove static community string in ifstatus.cfg
|
||||||
* add 28_check_tcp.expect_reporting.dpatch to fix broken response for
|
* add 28_check_tcp.expect_reporting.dpatch to fix broken response for
|
||||||
check_jabber
|
check_jabber
|
||||||
|
* add 29_check_tcp.check_jabber-returns-warning.dpatch to fix return of
|
||||||
|
check_jabber (closes: #392610).
|
||||||
|
|
||||||
-- sean finney <seanius@copelandia.seanius.net> Wed, 6 Dec 2006 23:47:12 +0100
|
-- sean finney <seanius@copelandia.seanius.net> Wed, 6 Dec 2006 23:47:12 +0100
|
||||||
|
|
||||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -8,3 +8,4 @@
|
||||||
26_implicit-basename.dpatch
|
26_implicit-basename.dpatch
|
||||||
27_check_radius_segfault.dpatch
|
27_check_radius_segfault.dpatch
|
||||||
28_check_tcp.expect_reporting.dpatch
|
28_check_tcp.expect_reporting.dpatch
|
||||||
|
29_check_tcp.check_jabber-returns-warning.dpatch
|
||||||
|
|
27
debian/patches/29_check_tcp.check_jabber-returns-warning.dpatch
vendored
Normal file
27
debian/patches/29_check_tcp.check_jabber-returns-warning.dpatch
vendored
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 29_check_tcp.check_jabber-returns-warning.dpatch
|
||||||
|
## Thomas Guyot-Sionnest <dermoth@aei.ca>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: No description.
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
Index: nagios-plugins-1.4.5/plugins/check_tcp.c
|
||||||
|
===================================================================
|
||||||
|
RCS file: /cvsroot/nagiosplug/nagiosplug/plugins/check_tcp.c,v
|
||||||
|
retrieving revision 1.84
|
||||||
|
diff -u -r1.84 check_tcp.c
|
||||||
|
--- nagios-plugins-1.4.5/plugins/check_tcp.c 30 Jan 2007 14:24:10 -0000 1.84
|
||||||
|
+++ nagios-plugins-1.4.5/plugins/check_tcp.c 31 Jan 2007 04:45:13 -0000
|
||||||
|
@@ -166,9 +166,9 @@
|
||||||
|
}
|
||||||
|
else if (!strncmp(SERVICE, "JABBER", 6)) {
|
||||||
|
SEND = "<stream:stream to=\'host\' xmlns=\'jabber:client\' xmlns:stream=\'http://etherx.jabber.org/streams\'>\n";
|
||||||
|
- EXPECT = "<?xml version=\'1.0\'?><stream:stream xmlns:stream=\'http://etherx.jabber.org/streams\'";
|
||||||
|
+ EXPECT = "<?xml version=\'1.0\'?><stream:stream xmlns=\'jabber:client\' xmlns:stream=\'http://etherx.jabber.org/streams\'";
|
||||||
|
QUIT = "</stream:stream>\n";
|
||||||
|
- flags |= FLAG_SSL | FLAG_HIDE_OUTPUT;
|
||||||
|
+ flags |= FLAG_HIDE_OUTPUT;
|
||||||
|
PORT = 5222;
|
||||||
|
}
|
||||||
|
else if (!strncmp (SERVICE, "NNTPS", 5)) {
|
Loading…
Reference in a new issue