[svn-buildpackage] Tagging nagios-plugins 1.4.15-4
This commit is contained in:
commit
55a1861118
4
debian/bin/gen_plugin_deps.pl
vendored
4
debian/bin/gen_plugin_deps.pl
vendored
|
@ -23,9 +23,9 @@ use strict;
|
||||||
use warnings;
|
use warnings;
|
||||||
|
|
||||||
# actual not needed
|
# actual not needed
|
||||||
#my $extra_deps = {
|
my $extra_deps = {
|
||||||
# sensors => [ 'lm-sensors' ],
|
# sensors => [ 'lm-sensors' ],
|
||||||
#};
|
};
|
||||||
|
|
||||||
my $infile = "debian/README.Debian.plugins.in";
|
my $infile = "debian/README.Debian.plugins.in";
|
||||||
my $outfile = "debian/README.Debian.plugins";
|
my $outfile = "debian/README.Debian.plugins";
|
||||||
|
|
12
debian/changelog
vendored
12
debian/changelog
vendored
|
@ -1,10 +1,16 @@
|
||||||
nagios-plugins (1.4.15-4) UNRELEASED; urgency=low
|
nagios-plugins (1.4.15-4) unstable; urgency=low
|
||||||
|
|
||||||
* Add 13_check_smtp_greeting.dpatch (Closes: #611914), thanks Daniel Piddock
|
* Add 13_check_smtp_greeting.dpatch (Closes: #611914), thanks Daniel Piddock
|
||||||
for spotting and Holger Weiss for providing a fix
|
for spotting and Holger Weiss for providing a fix
|
||||||
- Abort immediately if we don't receive a server greeting or if the
|
- Abort immediately if we don't receive a server greeting or if the
|
||||||
greeting doesn't contain the "--expect"ed string (by default: "220")
|
greeting doesn't contain the "--expect"ed string (by default: "220")
|
||||||
instead of blindly sending the EHLO/HELO line.
|
instead of blindly sending the EHLO/HELO line.
|
||||||
|
* Add 14_check_icmp_multiple_ips.dpatch (Closes: #623702), thanks Max Kosmach
|
||||||
|
for spotting and Sebastian Harl for providing a fix
|
||||||
|
- When specifying a host-name on the command line, each of its IPs is added
|
||||||
|
to the host table (and each one is pinged). So, the buffer has to be large
|
||||||
|
enough to hold all of the respective host objects. (argc - 1) only fits
|
||||||
|
hosts with a single IP.
|
||||||
* Move libraries linked at compile time against checks of
|
* Move libraries linked at compile time against checks of
|
||||||
nagios-plugins-standard from Depends to Recommends (Closes: #569028)
|
nagios-plugins-standard from Depends to Recommends (Closes: #569028)
|
||||||
- Add slightly modified bin/gen_plugin_deps.pl from collectd source package
|
- Add slightly modified bin/gen_plugin_deps.pl from collectd source package
|
||||||
|
@ -14,9 +20,9 @@ nagios-plugins (1.4.15-4) UNRELEASED; urgency=low
|
||||||
- Create customized substvars for nagios-plugins-standard via
|
- Create customized substvars for nagios-plugins-standard via
|
||||||
dpkg-shlibdeps in debian/rules
|
dpkg-shlibdeps in debian/rules
|
||||||
- Remove temporary files via clean target in debian/rules
|
- Remove temporary files via clean target in debian/rules
|
||||||
- Add hint to NEWS.DebianAdd hint to NEWS.Debia
|
- Add hint to NEWS.Debian
|
||||||
|
|
||||||
-- Jan Wagner <waja@cyconet.org> Mon, 27 Dec 2010 22:13:48 +0100
|
-- Jan Wagner <waja@cyconet.org> Wed, 18 May 2011 16:31:35 +0200
|
||||||
|
|
||||||
nagios-plugins (1.4.15-3) unstable; urgency=low
|
nagios-plugins (1.4.15-3) unstable; urgency=low
|
||||||
|
|
||||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -6,3 +6,4 @@
|
||||||
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
||||||
12_check_snmp_1.4.15_regression.dpatch
|
12_check_snmp_1.4.15_regression.dpatch
|
||||||
13_check_smtp_greeting.dpatch
|
13_check_smtp_greeting.dpatch
|
||||||
|
14_check_icmp_multiple_ips.dpatch
|
||||||
|
|
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 14_check_icmp_multiple_ips.dpatch
|
||||||
|
## Sebastian Harl <sh@teamix.net>
|
||||||
|
##
|
||||||
|
## From: 1374f80872412b64bd13f17e6edd70aa59437012 Mon Sep 17 00:00:00 2001
|
||||||
|
## From: Sebastian Harl <sh@teamix.net>
|
||||||
|
## Date: Thu, 28 Apr 2011 09:18:21 +0200
|
||||||
|
## Subject: [PATCH] check_host: Allocate a large-enough buffer for the host table.
|
||||||
|
## (Debian #623702)
|
||||||
|
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=1374f80872412b64bd13f17e6edd70aa59437012
|
||||||
|
##
|
||||||
|
## DP: Allocate a large-enough buffer for the host table. (http://bugs.debian.org/623702)
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
|
||||||
|
--- a/plugins-root/check_icmp.c
|
||||||
|
+++ b/plugins-root/check_icmp.c
|
||||||
|
@@ -621,7 +621,7 @@ main(int argc, char **argv)
|
||||||
|
}
|
||||||
|
|
||||||
|
host = list;
|
||||||
|
- table = malloc(sizeof(struct rta_host **) * (argc - 1));
|
||||||
|
+ table = malloc(sizeof(struct rta_host **) * targets);
|
||||||
|
i = 0;
|
||||||
|
while(host) {
|
||||||
|
host->id = i*packets;
|
||||||
|
|
32
debian/patches/15_check_sensors_fault.dpatch
vendored
Executable file
32
debian/patches/15_check_sensors_fault.dpatch
vendored
Executable file
|
@ -0,0 +1,32 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 15_check_sensors_fault.dpatch by Jan Wagner <waja@cyconet.org>
|
||||||
|
##
|
||||||
|
## DP: Report UNKNOWN if sensor is faulty (fixing #615133)
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.15~/plugins-scripts/check_sensors.sh nagios-plugins-1.4.15/plugins-scripts/check_sensors.sh
|
||||||
|
--- nagios-plugins-1.4.15~/plugins-scripts/check_sensors.sh 2010-07-27 22:47:16.000000000 +0200
|
||||||
|
+++ nagios-plugins-1.4.15/plugins-scripts/check_sensors.sh 2011-05-17 22:17:38.000000000 +0200
|
||||||
|
@@ -10,7 +10,7 @@
|
||||||
|
|
||||||
|
|
||||||
|
print_usage() {
|
||||||
|
- echo "Usage: $PROGNAME"
|
||||||
|
+ echo "Usage: $PROGNAME [--ignore-fault]"
|
||||||
|
}
|
||||||
|
|
||||||
|
print_help() {
|
||||||
|
@@ -57,6 +57,13 @@
|
||||||
|
if echo ${sensordata} | egrep ALARM > /dev/null; then
|
||||||
|
echo SENSOR CRITICAL - Sensor alarm detected!
|
||||||
|
exit 2
|
||||||
|
+ elif echo ${sensordata} | egrep FAULT > /dev/null; then
|
||||||
|
+ echo SENSOR UNKNOWN - Sensor reported fault
|
||||||
|
+ if test "$1" != "-i" -a "$1" != "--ignore-fault"; then
|
||||||
|
+ exit 3
|
||||||
|
+ else
|
||||||
|
+ exit 0
|
||||||
|
+ fi
|
||||||
|
else
|
||||||
|
echo sensor ok
|
||||||
|
exit 0
|
Loading…
Reference in a new issue