allow empty ldap base

This commit is contained in:
Jan Wagner 2008-06-06 11:47:27 +00:00
parent eed6fd1682
commit 5cc06623c7
3 changed files with 23 additions and 0 deletions

3
debian/changelog vendored
View file

@ -32,6 +32,9 @@ nagios-plugins (1.4.12-1) UNRELEASED; urgency=low
(Closes: #478942) (Closes: #478942)
* add 35_check_http_date.dpatch which fixes date parsing of check_http, * add 35_check_http_date.dpatch which fixes date parsing of check_http,
thanks Hilko Bengen <bengen@debian.org> for providing it (Closes: #460097) thanks Hilko Bengen <bengen@debian.org> for providing it (Closes: #460097)
* add 36_check_ldap_empty_base.dpatch which allows empty ldap base, thanks
to Stephane Chazelas <stephane@artesyncp.com> for providing it
(Closes: #479984)
[ Alexander Wirt ] [ Alexander Wirt ]
* Call smbclient with -N (supress password prompt) if no password is * Call smbclient with -N (supress password prompt) if no password is

View file

@ -10,4 +10,5 @@
33_fix_emb_check_disk_smb.dpatch 33_fix_emb_check_disk_smb.dpatch
34_fix_smbclient_check_disk_smb.dpatch 34_fix_smbclient_check_disk_smb.dpatch
35_check_http_date.dpatch 35_check_http_date.dpatch
36_check_ldap_empty_base.dpatch
50_misc_typos.dpatch 50_misc_typos.dpatch

View file

@ -0,0 +1,19 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 36_check_ldap_empty_base.dpatch by Jan Wagner <waja@cyconet.org>
## patch provided by Stephane Chazelas <stephane@artesyncp.com>
##
## DP: allow empty ldap base
@DPATCH@
diff -urNad nagios-plugins-1.4.12~/plugins/check_ldap.c nagios-plugins-1.4.12/plugins/check_ldap.c
--- nagios-plugins-1.4.12~/plugins/check_ldap.c 2008-06-06 13:40:44.000000000 +0200
+++ nagios-plugins-1.4.12/plugins/check_ldap.c 2008-06-06 13:42:02.000000000 +0200
@@ -378,7 +378,7 @@
if (ld_host==NULL || strlen(ld_host)==0)
usage4 (_("Please specify the host name\n"));
- if (ld_base==NULL || strlen(ld_base)==0)
+ if (ld_base == NULL)
usage4 (_("Please specify the LDAP base\n"));
return OK;