remove check_bgpstate and check_linux_raid

This commit is contained in:
Jan Wagner 2012-05-15 12:01:24 +00:00
parent e6b4a0267d
commit 5f7798328e
6 changed files with 16 additions and 69 deletions

12
debian/NEWS.Debian vendored
View file

@ -1,3 +1,15 @@
nagios-plugins (1.4.15-6) unstable; urgency=low
Created a nagios-plugins-common package which ships files possibly needed
also by other plugin packages and should installed as dependency
Removed check_bgpstate and check_linux_raid, which are shiped in upstream
contrib/ and are not maintained there anymore. If you need a replacement
for check_linux_raid, have a look into check_raid from
nagios-plugins-contrib package.
-- Jan Wagner <waja@cyconet.org> Tue, 15 May 2012 13:41:33 +0200
nagios-plugins (1.4.15-4) unstable; urgency=low nagios-plugins (1.4.15-4) unstable; urgency=low
Moved linked libraries against nagios-plugins-standard from Depends to Moved linked libraries against nagios-plugins-standard from Depends to

2
debian/changelog vendored
View file

@ -2,6 +2,8 @@ nagios-plugins (1.4.15-6) UNRELEASED; urgency=low
* Add nagios-plugins-common package which ships files possibly needed also by * Add nagios-plugins-common package which ships files possibly needed also by
other plugin packages other plugin packages
* Removed check_bgpstate and check_linux_raid from package
- Deleted 01_subst.in.dpatch and 05_check_linux_raid_fix_striped.dpatch
* Add icinga as recommand as alternative for nagios3 * Add icinga as recommand as alternative for nagios3
* Add '-w %d' as ping argument for check_ping on non-linux plattforms, as * Add '-w %d' as ping argument for check_ping on non-linux plattforms, as
inetutils-ping is now supporting this, thanks Guillem Jover for bringing inetutils-ping is now supporting this, thanks Guillem Jover for bringing

View file

@ -1,7 +1,5 @@
01_subst.in.dpatch
02_check_icmp_links.dpatch 02_check_icmp_links.dpatch
# commited upstream # commited upstream
05_check_linux_raid_fix_striped.dpatch
10_check_disk_smb_spaces.dpatch 10_check_disk_smb_spaces.dpatch
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch 11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
12_check_snmp_1.4.15_regression.dpatch 12_check_snmp_1.4.15_regression.dpatch

View file

@ -1,18 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 01_subst.in.dpatch by <seanius@localhost.localdomain>
##
## DP: Use /usr/lib/nagios/plugins as path.
@DPATCH@
diff -urNad nagios-plugins-1.4.12~/contrib/check_linux_raid.pl nagios-plugins-1.4.12/contrib/check_linux_raid.pl
--- nagios-plugins-1.4.12~/contrib/check_linux_raid.pl 2007-08-28 05:19:45.000000000 +0200
+++ nagios-plugins-1.4.12/contrib/check_linux_raid.pl 2008-06-06 16:16:23.000000000 +0200
@@ -23,7 +23,7 @@
# WARNING md0 status=[UUU_U], recovery=46.4%, finish=123.0min
use strict;
-use lib "/usr/local/nagios/libexec";
+use lib "/usr/lib/nagios/plugins";
use utils qw(%ERRORS);
# die with an error if we're not on Linux

View file

@ -1,47 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 05_check_linux_raid_fix_striped.dpatch by Thomas Guyot-Sionnest <dermoth@aei.ca>
##
## DP: Fix RAID0 and linear volumes (http://bugs.debian.org/579049)
## DP: Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/nagios-plugins/+bug/621380
## DP: Upstream bug is: http://sourceforge.net/tracker/?func=detail&aid=3049988&group_id=29880&atid=397597
@DPATCH@
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.15~/contrib/check_linux_raid.pl nagios-plugins-1.4.15/contrib/check_linux_raid.pl
--- nagios-plugins-1.4.15~/contrib/check_linux_raid.pl 2010-07-27 22:47:15.000000000 +0200
+++ nagios-plugins-1.4.15/contrib/check_linux_raid.pl 2010-09-23 09:00:11.000000000 +0200
@@ -71,7 +71,8 @@
} elsif (/^($nextdev)\s*:/) {
$device=$1;
$devices{$device}=$device;
- if (/active/) {
+ if (/\sactive/) {
+ $status{$device} = ''; # Shall be filled later if available
$active{$device} = 1;
}
}
@@ -80,7 +81,11 @@
}
foreach my $k (sort keys %devices){
- if ($status{$k} =~ /_/) {
+ if (!exists($status{$k})) {
+ $msg .= sprintf " %s inactive with no status information.",
+ $devices{$k};
+ $code = max_state($code, "CRITICAL");
+ } elsif ($status{$k} =~ /_/) {
if (defined $recovery{$k}) {
$msg .= sprintf " %s status=%s, recovery=%s, finish=%s.",
$devices{$k}, $status{$k}, $recovery{$k}, $finish{$k};
@@ -94,10 +99,11 @@
$code = max_state($code, "OK");
} else {
if ($active{$k}) {
- $msg .= sprintf " %s active with no status information.\n",
+ $msg .= sprintf " %s active with no status information.",
$devices{$k};
$code = max_state($code, "OK");
} else {
+ # This should't run anymore, but is left as a catch-all
$msg .= sprintf " %s does not exist.\n", $devices{$k};
$code = max_state($code, "CRITICAL");
}

4
debian/rules vendored
View file

@ -167,8 +167,8 @@ install: build
cp $(DEBIANDIR)/pluginconfig/$${c}.cfg ${NP_STD_TEMPLATES}; \ cp $(DEBIANDIR)/pluginconfig/$${c}.cfg ${NP_STD_TEMPLATES}; \
done done
# install check_bgpstate from contrib # install check_bgpstate from contrib
install -m 755 contrib/check_bgpstate.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_bgpstate #install -m 755 contrib/check_bgpstate.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_bgpstate
install -m 755 contrib/check_linux_raid.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_linux_raid #install -m 755 contrib/check_linux_raid.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_linux_raid
# dynamically create the postrm scripts using a template, so that we # dynamically create the postrm scripts using a template, so that we
# don't have to define the same list of plugin configs over and over. # don't have to define the same list of plugin configs over and over.
sed -e 's/@BASIC_PLUGINS@/${basic_plugin_cfgs}/' \ sed -e 's/@BASIC_PLUGINS@/${basic_plugin_cfgs}/' \