add patches for check_disk_smb

This commit is contained in:
Jan Wagner 2010-11-30 11:50:44 +00:00
parent 99e8c3603d
commit 604166c36e
4 changed files with 64 additions and 2 deletions

5
debian/changelog vendored
View file

@ -1,6 +1,9 @@
nagios-plugins (1.4.15-3) UNRELEASED; urgency=low
* NOT RELEASED YET
* Add 10_check_disk_smb_spaces.dpatch from upstream svn (Closes: #601699),
thanks to Adam Buchbinder
* Add 11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch from upstream svn
(Closes: #601696), thanks to Adam Buchbinder
-- Jan Wagner <waja@cyconet.org> Thu, 23 Sep 2010 11:24:55 +0200

View file

@ -1,4 +1,6 @@
01_subst.in.dpatch
02_check_icmp_links.dpatch
05_check_linux_raid_fix_striped.dpatch
# commited upstream
05_check_linux_raid_fix_striped.dpatch
10_check_disk_smb_spaces.dpatch
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch

View file

@ -0,0 +1,29 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 10_check_disk_smb_spaces.dpatch by
## Matthias Eble <psychotrahe@users.sourceforge.net>
##
## From 0892c4ac28c4c2e3b6275187f845813b4cd6d320 Mon Sep 17 00:00:00 2001
## From: Matthias Eble <psychotrahe@users.sourceforge.net>
## Date: Sun, 28 Nov 2010 21:35:59 +0100
## Subject: [PATCH] Make check_disk_smb accept spaces in share names
## (#990948, #1370031, Debian #601699)
##
## DP: Enables Support sharenames with spaces (http://bugs.debian.org/601699)
## DP: Upstream bug is: http://sourceforge.net/tracker/?func=detail&aid=990948&group_id=29880&atid=397597
@DPATCH@
diff --git a/plugins-scripts/check_disk_smb.pl b/plugins-scripts/check_disk_smb.pl
index 7c81fc2..4698700 100755
--- a/plugins-scripts/check_disk_smb.pl
+++ b/plugins-scripts/check_disk_smb.pl
@@ -67,7 +67,7 @@ my $host = $1 if ($opt_H =~ /^([-_.A-Za-z0-9 ]+\$?)$/);
($host) || usage("Invalid host: $opt_H\n");
($opt_s) || ($opt_s = shift @ARGV) || usage("Share volume not specified\n");
-my $share = $1 if ($opt_s =~ /^([-_.A-Za-z0-9]+\$?)$/);
+my $share = $1 if ($opt_s =~ /^([-_.A-Za-z0-9 ]+\$?)$/);
($share) || usage("Invalid share: $opt_s\n");
defined($opt_u) || ($opt_u = shift @ARGV) || ($opt_u = "guest");

View file

@ -0,0 +1,28 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch by
## Matthias Eble <psychotrahe@users.sourceforge.net>
##
## From 3c67c9cb60a4681a29e509fccbb333e0f6234f54 Mon Sep 17 00:00:00 2001
## From: Matthias Eble <psychotrahe@users.sourceforge.net>
## Date: Sun, 28 Nov 2010 21:43:48 +0100
## Subject: [PATCH] check_disk_smb now handles NT_STATUS_ACCESS_DENIED properly
## (Debian #601696)
##
## DP: Handles NT_STATUS_ACCESS_DENIED properly (http://bugs.debian.org/601696)
@DPATCH@
diff --git a/plugins-scripts/check_disk_smb.pl b/plugins-scripts/check_disk_smb.pl
index 4698700..6783543 100755
--- a/plugins-scripts/check_disk_smb.pl
+++ b/plugins-scripts/check_disk_smb.pl
@@ -239,7 +239,7 @@ if (/\s*(\d*) blocks of size (\d*)\. (\d*) blocks available/) {
$answer = "Result from smbclient not suitable\n";
$state = "UNKNOWN";
foreach (@lines) {
- if (/(Access denied|NT_STATUS_LOGON_FAILURE)/) {
+ if (/(Access denied|NT_STATUS_LOGON_FAILURE|NT_STATUS_ACCESS_DENIED)/) {
$answer = "Access Denied\n";
$state = "CRITICAL";
last;