return Warning when rebuilding volume

This commit is contained in:
Jan Wagner 2010-03-19 14:41:31 +00:00
parent d42ef6d01a
commit 6464c1334f
2 changed files with 19 additions and 0 deletions

2
debian/changelog vendored
View file

@ -4,6 +4,8 @@ nagios-plugins (1.4.14-3) UNRELEASED; urgency=medium
* Move postfix | sendmail-bin | exim4-daemon-heavy | exim4-daemon-light
to Suggests, thanks to Glennie Vignarajah (CLoses: #574591)
* Install NEWS.Debian and README.Debian* to the appropriate packages
* Add 42_check_linux_raid_fix_rebuild.dpatch to return Warning when
rebuilding volume, thanks to Christoph Martin (CLoses: #574612)
-- Jan Wagner <waja@cyconet.org> Tue, 16 Mar 2010 09:35:20 +0100

View file

@ -0,0 +1,17 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 42_check_linux_raid_fix_rebuild.dpatch by Christoph Martin <martin@uni-mainz.de>
##
## DP: Return Warning when rebuilding volume
@DPATCH@
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.14~/contrib/check_linux_raid.pl nagios-plugins-1.4.14/contrib/check_linux_raid.pl
--- nagios-plugins-1.4.14~/contrib/check_linux_raid.pl 2010-03-19 15:35:24.000000000 +0100
+++ nagios-plugins-1.4.14/contrib/check_linux_raid.pl 2010-03-19 15:37:35.000000000 +0100
@@ -64,6 +64,7 @@
} elsif (/recovery = (.*?)\s/) {
$recovery{$device} = $1;
($finish{$device}) = /finish=(.*?min)/;
+ $device=undef;
} elsif (/^\s*$/) {
$device=undef;
}