+ * include fix for braindead behaviour in check_tcp based plugins
+ such as check_simap (closes: #351847). (note: fix also committed in upstream CVS)
This commit is contained in:
parent
93ba32ae79
commit
70c0368c56
4
debian/changelog
vendored
4
debian/changelog
vendored
|
@ -1,8 +1,10 @@
|
||||||
nagios-plugins (1.4.3.0cvs.20060707-4) UNRELEASED; urgency=low
|
nagios-plugins (1.4.3.0cvs.20060707-4) UNRELEASED; urgency=low
|
||||||
|
|
||||||
* NOT RELEASED YET
|
* NOT RELEASED YET
|
||||||
|
* include fix for braindead behaviour in check_tcp based plugins
|
||||||
|
such as check_simap (closes: #351847).
|
||||||
|
|
||||||
-- sean finney <sean@localhost> Fri, 4 Aug 2006 09:01:30 -0700
|
-- sean finney <seanius@debian.org> Sat, 02 Sep 2006 23:03:45 +0200
|
||||||
|
|
||||||
nagios-plugins (1.4.3.0cvs.20060707-3) unstable; urgency=high
|
nagios-plugins (1.4.3.0cvs.20060707-3) unstable; urgency=high
|
||||||
|
|
||||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -5,3 +5,4 @@
|
||||||
18_check_game_cmdline.dpatch
|
18_check_game_cmdline.dpatch
|
||||||
22_check_smb_hostaddress.dpatch
|
22_check_smb_hostaddress.dpatch
|
||||||
23_check_axis.dpatch
|
23_check_axis.dpatch
|
||||||
|
25_check_tcp.c_warncritopts.diff
|
||||||
|
|
39
debian/patches/25_check_tcp.c_warncritopts.diff
vendored
Normal file
39
debian/patches/25_check_tcp.c_warncritopts.diff
vendored
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
@DPATCH@
|
||||||
|
diff -u -u -r1.78 check_tcp.c
|
||||||
|
--- old/plugins/check_tcp.c 29 Mar 2006 16:33:36 -0000 1.78
|
||||||
|
+++ new/plugins/check_tcp.c 2 Sep 2006 20:28:58 -0000
|
||||||
|
@@ -373,8 +373,8 @@
|
||||||
|
int option = 0;
|
||||||
|
static struct option longopts[] = {
|
||||||
|
{"hostname", required_argument, 0, 'H'},
|
||||||
|
- {"critical-time", required_argument, 0, 'c'},
|
||||||
|
- {"warning-time", required_argument, 0, 'w'},
|
||||||
|
+ {"critical", required_argument, 0, 'c'},
|
||||||
|
+ {"warning", required_argument, 0, 'w'},
|
||||||
|
{"critical-codes", required_argument, 0, 'C'},
|
||||||
|
{"warning-codes", required_argument, 0, 'W'},
|
||||||
|
{"timeout", required_argument, 0, 't'},
|
||||||
|
@@ -454,20 +454,14 @@
|
||||||
|
server_address = optarg;
|
||||||
|
break;
|
||||||
|
case 'c': /* critical */
|
||||||
|
- if (!is_intnonneg (optarg))
|
||||||
|
- usage4 (_("Critical threshold must be a positive integer"));
|
||||||
|
- else
|
||||||
|
- critical_time = strtod (optarg, NULL);
|
||||||
|
+ critical_time = strtod (optarg, NULL);
|
||||||
|
flags |= FLAG_TIME_CRIT;
|
||||||
|
break;
|
||||||
|
case 'j': /* hide output */
|
||||||
|
flags |= FLAG_HIDE_OUTPUT;
|
||||||
|
break;
|
||||||
|
case 'w': /* warning */
|
||||||
|
- if (!is_intnonneg (optarg))
|
||||||
|
- usage4 (_("Warning threshold must be a positive integer"));
|
||||||
|
- else
|
||||||
|
- warning_time = strtod (optarg, NULL);
|
||||||
|
+ warning_time = strtod (optarg, NULL);
|
||||||
|
flags |= FLAG_TIME_WARN;
|
||||||
|
break;
|
||||||
|
case 'C':
|
Loading…
Reference in a new issue