Add patch from Josep Rodin to check_smb_disk (#425129)

This commit is contained in:
Alexander Wirt 2008-05-02 05:37:40 +00:00
parent 9f5862629d
commit 721938b405
4 changed files with 27 additions and 2 deletions

8
debian/changelog vendored
View file

@ -1,5 +1,6 @@
nagios-plugins (1.4.11-3) UNRELEASED; urgency=low
[ Jan Wagner ]
* remove unneeded debhelper scripts from rules
* remove senseless comments from patches
* add missing descriptions to patches
@ -7,7 +8,12 @@ nagios-plugins (1.4.11-3) UNRELEASED; urgency=low
<robe@amd.co.at> for reporting it (Closes: #407310)
* remove sarge handholding for configfiles migration
-- Jan Wagner <waja@cyconet.org> Fri, 07 Mar 2008 17:37:49 +0100
[ Alexander Wirt ]
* Call smbclient with -N (supress password prompt) if no password is
supplied. Thanks to Josip Rodin for the patch (Closes #425129)
* Add myself to uploaders
-- Alexander Wirt <formorer@debian.org> Fri, 02 May 2008 07:35:54 +0200
nagios-plugins (1.4.11-2) unstable; urgency=low

2
debian/control vendored
View file

@ -2,7 +2,7 @@ Source: nagios-plugins
Section: net
Priority: extra
Maintainer: Debian Nagios Maintainer Group <pkg-nagios-devel@lists.alioth.debian.org>
Uploaders: Sean Finney <seanius@debian.org>, Guido Trotter <ultrotter@debian.org>, Jan Wagner <waja@cyconet.org>
Uploaders: Sean Finney <seanius@debian.org>, Guido Trotter <ultrotter@debian.org>, Jan Wagner <waja@cyconet.org>, Alexander Wirt <formorer@debian.org>
Build-Depends: debhelper (>= 4.0.0), dpatch (>= 2.0.9), autotools-dev, libldap2-dev, libpq-dev, libmysqlclient15-dev | libmysqlclient12-dev | libmysqlclient-dev, libradius1-dev, libkrb5-dev, libnet-snmp-perl, procps, coreutils, mawk | awk
Homepage: http://nagiosplug.sourceforge.net
Vcs-Browser: http://svn.debian.org/wsvn/pkg-nagios/nagios-plugins/

View file

@ -3,6 +3,7 @@
14_check_log_paths.dpatch
18_check_game_cmdline.dpatch
22_check_smb_hostaddress.dpatch
23_check_smb_password.dpatch
26_implicit-basename.dpatch
27_check_radius_segfault.dpatch
28_check_pgsql_include_for_8.3.dpatch

18
debian/patches/23_check_smb_password.dpatch vendored Executable file
View file

@ -0,0 +1,18 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 23_check_smb_password.dpatch by Alexander Wirt <formorer@debian.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: If there is no password set call smbclient with -N (suppress password prompt)
@DPATCH@
diff -urNad nagios-plugins-1.4.11~/plugins-scripts/check_disk_smb.pl nagios-plugins-1.4.11/plugins-scripts/check_disk_smb.pl
--- nagios-plugins-1.4.11~/plugins-scripts/check_disk_smb.pl 2008-05-02 07:13:08.000000000 +0200
+++ nagios-plugins-1.4.11/plugins-scripts/check_disk_smb.pl 2008-05-02 07:15:23.000000000 +0200
@@ -79,6 +79,7 @@
($opt_p) || ($opt_p = shift) || ($opt_p = "");
my $pass = $1 if ($opt_p =~ /(.*)/);
+$pass = "-N" if ($opt_p eq "");
($opt_w) || ($opt_w = shift) || ($opt_w = 85);
my $warn = $1 if ($opt_w =~ /^([0-9]{1,2}\%?|100\%?|[0-9]+[kMG])$/);