sometic changes to changelog

This commit is contained in:
Jan Wagner 2010-01-23 12:15:09 +00:00
parent 72a1713934
commit 739e9ca1cc
2 changed files with 19 additions and 2 deletions

4
debian/changelog vendored
View file

@ -1,6 +1,6 @@
nagios-plugins (1.4.14-2) UNRELEASED; urgency=low
* NOT RELEASED YET
* cosmetic change to last changelog entry
-- Jan Wagner <waja@cyconet.org> Sat, 23 Jan 2010 01:39:31 +0100
@ -23,7 +23,7 @@ nagios-plugins (1.4.14-1) unstable; urgency=low
* Update 06_checkircd.dpatch, which got fixed upstream
* Add 40_check_http_proxy_auth.dpatch to make check_http able to check proxy
authorization
* Update copyright, thanks to Robert Millan (Closes: 548303)
* Update copyright, thanks to Robert Millan (Closes: #548303)
* Depend on inetutils-ping on kfreebsd and hurd, thanks to Petr Salinger
(Closes: #555532)
- Use '-n -c %d %s' as ping argument on archs where inetutils-ping is used

View file

@ -0,0 +1,17 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 01_check_apt_return_unknown.dpatch by Jan Wagner <waja@cyconet.org>
##
## DP: Return UNKNOWN, if we don't know what happens (#498812)
@DPATCH@
--- nagios-plugins-1.4.14~/plugins/check_apt.c 2009-10-16 00:20:03.000000000 +0200
+++ nagios-plugins-1.4.14/plugins/check_apt.c 2009-10-16 00:20:38.000000000 +0200
@@ -291,7 +291,7 @@
/* If we get anything on stderr, at least set warning */
if(chld_err.buflen){
stderr_warning=1;
- result = max_state(result, STATE_WARNING);
+ result = max_state_alt(result, STATE_UNKNOWN);
if(verbose){
for(i = 0; i < chld_err.lines; i++) {
fprintf(stderr, "%s\n", chld_err.line[i]);