Add patch to fix FTBFS with MariaDB 10.3. (closes: #919375)
This commit is contained in:
parent
377eec3be3
commit
7fafae5386
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -2,6 +2,8 @@ monitoring-plugins (2.2-5) UNRELEASED; urgency=medium
|
||||||
|
|
||||||
[ Bas Couwenberg ]
|
[ Bas Couwenberg ]
|
||||||
* Bump Standards-Version to 4.3.0, no changes.
|
* Bump Standards-Version to 4.3.0, no changes.
|
||||||
|
* Add patch to fix FTBFS with MariaDB 10.3.
|
||||||
|
(closes: #919375)
|
||||||
|
|
||||||
[ Andreas Henriksson ]
|
[ Andreas Henriksson ]
|
||||||
* Pass PATH_TO_APTGET=/usr/bin/apt-get to configure
|
* Pass PATH_TO_APTGET=/usr/bin/apt-get to configure
|
||||||
|
|
30
debian/patches/mariadb-10.3.patch
vendored
Normal file
30
debian/patches/mariadb-10.3.patch
vendored
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
Description: Add support for MariaDB 10.3.
|
||||||
|
Author: Bas Couwenberg <sebastic@debian.org>
|
||||||
|
Bug-Debian: https://bugs.debian.org/919395
|
||||||
|
|
||||||
|
--- a/plugins/check_mysql.c
|
||||||
|
+++ b/plugins/check_mysql.c
|
||||||
|
@@ -45,6 +45,10 @@ const char *email = "devel@monitoring-pl
|
||||||
|
#include <mysqld_error.h>
|
||||||
|
#include <errmsg.h>
|
||||||
|
|
||||||
|
+#ifndef MYSQL_PORT
|
||||||
|
+#define MYSQL_PORT 3306
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
char *db_user = NULL;
|
||||||
|
char *db_host = NULL;
|
||||||
|
char *db_socket = NULL;
|
||||||
|
--- a/plugins/check_mysql_query.c
|
||||||
|
+++ b/plugins/check_mysql_query.c
|
||||||
|
@@ -41,6 +41,10 @@ const char *email = "devel@monitoring-pl
|
||||||
|
#include <mysql.h>
|
||||||
|
#include <errmsg.h>
|
||||||
|
|
||||||
|
+#ifndef MYSQL_PORT
|
||||||
|
+#define MYSQL_PORT 3306
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
char *db_user = NULL;
|
||||||
|
char *db_host = NULL;
|
||||||
|
char *db_socket = NULL;
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -4,3 +4,4 @@
|
||||||
11_check_dhcp_MSG_PEAK
|
11_check_dhcp_MSG_PEAK
|
||||||
12_check_apt_only_crit
|
12_check_apt_only_crit
|
||||||
13_check_apt_list_packages
|
13_check_apt_list_packages
|
||||||
|
mariadb-10.3.patch
|
||||||
|
|
Loading…
Reference in a new issue