new upstream
This commit is contained in:
parent
b5131092bf
commit
87edb050c2
16
debian/changelog
vendored
16
debian/changelog
vendored
|
@ -1,6 +1,18 @@
|
|||
nagios-plugins (1.4.15-8) UNRELEASED; urgency=low
|
||||
nagios-plugins (1.4.16~pre1-1) UNRELEASED; urgency=low
|
||||
|
||||
* NOT RELEASED YET
|
||||
* New upstream snapshot
|
||||
* Droped the following upstream integrated patches
|
||||
- 10_check_disk_smb_spaces.dpatch
|
||||
- 11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
||||
- 12_check_snmp_1.4.15_regression.dpatch
|
||||
- 13_check_smtp_greeting.dpatch
|
||||
- 14_check_icmp_multiple_ips.dpatch
|
||||
- 15_check_sensors_fault.dpatch
|
||||
- 16_check_raduis_fix_format-security.dpatch
|
||||
- 17_check_tcp_fix_duplicate_cert_message.dpatch
|
||||
- 17_check_smtp_fix_duplicate_cert_message.dpatch
|
||||
- 18_check_snmp_labels.dpatch
|
||||
- 19_check_http_help.dpatch
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Tue, 22 May 2012 21:07:50 +0200
|
||||
|
||||
|
|
11
debian/patches/00list
vendored
11
debian/patches/00list
vendored
|
@ -1,14 +1,3 @@
|
|||
02_check_icmp_links.dpatch
|
||||
# commited upstream
|
||||
10_check_disk_smb_spaces.dpatch
|
||||
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
||||
12_check_snmp_1.4.15_regression.dpatch
|
||||
13_check_smtp_greeting.dpatch
|
||||
14_check_icmp_multiple_ips.dpatch
|
||||
15_check_sensors_fault.dpatch
|
||||
16_check_raduis_fix_format-security.dpatch
|
||||
17_check_tcp_fix_duplicate_cert_message.dpatch
|
||||
17_check_smtp_fix_duplicate_cert_message.dpatch
|
||||
03_check_disk_smb_perfdata.dpatch
|
||||
18_check_snmp_labels.dpatch
|
||||
19_check_http_help.dpatch
|
||||
|
|
29
debian/patches/10_check_disk_smb_spaces.dpatch
vendored
29
debian/patches/10_check_disk_smb_spaces.dpatch
vendored
|
@ -1,29 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 10_check_disk_smb_spaces.dpatch by
|
||||
## Matthias Eble <psychotrahe@users.sourceforge.net>
|
||||
##
|
||||
## From 0892c4ac28c4c2e3b6275187f845813b4cd6d320 Mon Sep 17 00:00:00 2001
|
||||
## From: Matthias Eble <psychotrahe@users.sourceforge.net>
|
||||
## Date: Sun, 28 Nov 2010 21:35:59 +0100
|
||||
## Subject: [PATCH] Make check_disk_smb accept spaces in share names
|
||||
## (#990948, #1370031, Debian #601699)
|
||||
##
|
||||
## DP: Enables Support sharenames with spaces (http://bugs.debian.org/601699)
|
||||
## DP: Upstream bug is: http://sourceforge.net/tracker/?func=detail&aid=990948&group_id=29880&atid=397597
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff --git a/plugins-scripts/check_disk_smb.pl b/plugins-scripts/check_disk_smb.pl
|
||||
index 7c81fc2..4698700 100755
|
||||
--- a/plugins-scripts/check_disk_smb.pl
|
||||
+++ b/plugins-scripts/check_disk_smb.pl
|
||||
@@ -67,7 +67,7 @@ my $host = $1 if ($opt_H =~ /^([-_.A-Za-z0-9 ]+\$?)$/);
|
||||
($host) || usage("Invalid host: $opt_H\n");
|
||||
|
||||
($opt_s) || ($opt_s = shift @ARGV) || usage("Share volume not specified\n");
|
||||
-my $share = $1 if ($opt_s =~ /^([-_.A-Za-z0-9]+\$?)$/);
|
||||
+my $share = $1 if ($opt_s =~ /^([-_.A-Za-z0-9 ]+\$?)$/);
|
||||
($share) || usage("Invalid share: $opt_s\n");
|
||||
|
||||
defined($opt_u) || ($opt_u = shift @ARGV) || ($opt_u = "guest");
|
||||
|
|
@ -1,28 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch by
|
||||
## Matthias Eble <psychotrahe@users.sourceforge.net>
|
||||
##
|
||||
## From 3c67c9cb60a4681a29e509fccbb333e0f6234f54 Mon Sep 17 00:00:00 2001
|
||||
## From: Matthias Eble <psychotrahe@users.sourceforge.net>
|
||||
## Date: Sun, 28 Nov 2010 21:43:48 +0100
|
||||
## Subject: [PATCH] check_disk_smb now handles NT_STATUS_ACCESS_DENIED properly
|
||||
## (Debian #601696)
|
||||
##
|
||||
## DP: Handles NT_STATUS_ACCESS_DENIED properly (http://bugs.debian.org/601696)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff --git a/plugins-scripts/check_disk_smb.pl b/plugins-scripts/check_disk_smb.pl
|
||||
index 4698700..6783543 100755
|
||||
--- a/plugins-scripts/check_disk_smb.pl
|
||||
+++ b/plugins-scripts/check_disk_smb.pl
|
||||
@@ -239,7 +239,7 @@ if (/\s*(\d*) blocks of size (\d*)\. (\d*) blocks available/) {
|
||||
$answer = "Result from smbclient not suitable\n";
|
||||
$state = "UNKNOWN";
|
||||
foreach (@lines) {
|
||||
- if (/(Access denied|NT_STATUS_LOGON_FAILURE)/) {
|
||||
+ if (/(Access denied|NT_STATUS_LOGON_FAILURE|NT_STATUS_ACCESS_DENIED)/) {
|
||||
$answer = "Access Denied\n";
|
||||
$state = "CRITICAL";
|
||||
last;
|
||||
|
|
@ -1,180 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 12_check_snmp_1.4.15_regression.dpatch by
|
||||
## Thomas Guyot-Sionnest <dermoth@aei.ca>
|
||||
##
|
||||
## Original patch to make Timeticks works as in check_snmp v1.4.14, it turns
|
||||
## out is_numeric isn't so useful and treating all types as numeric works
|
||||
## best for backwards-compatibility. This is how it used to work in 1.4.14.
|
||||
##
|
||||
## As a special case, I also make calculate_rate look up for numeric values
|
||||
## as it would otherwise return the last value instead.
|
||||
##
|
||||
## DP: Remove that is_numeric madness
|
||||
|
||||
@DPATCH@
|
||||
|
||||
|
||||
diff --git a/NEWS b/NEWS
|
||||
index ff92401..e3e8f37 100644
|
||||
--- a/NEWS
|
||||
+++ b/NEWS
|
||||
@@ -1,5 +1,10 @@
|
||||
This file documents the major additions and syntax changes between releases.
|
||||
|
||||
+ ...
|
||||
+
|
||||
+ FIXES
|
||||
+ Make check_snmp work more like v1.4.14 with regard to using special values (Timeticks, STRING) as numeric thresholds.
|
||||
+
|
||||
1.4.15 27th July 2010
|
||||
ENHANCEMENTS
|
||||
New check_ntp_peer -m and -n options to check the number of usable time sources ("truechimers")
|
||||
diff --git a/plugins/check_snmp.c b/plugins/check_snmp.c
|
||||
index f32a26e..d79da8c 100644
|
||||
--- a/plugins/check_snmp.c
|
||||
+++ b/plugins/check_snmp.c
|
||||
@@ -169,7 +169,6 @@ main (int argc, char **argv)
|
||||
char *state_string=NULL;
|
||||
size_t response_length, current_length, string_length;
|
||||
char *temp_string=NULL;
|
||||
- int is_numeric=0;
|
||||
time_t current_time;
|
||||
double temp_double;
|
||||
time_t duration;
|
||||
@@ -335,29 +334,24 @@ main (int argc, char **argv)
|
||||
/* We strip out the datatype indicator for PHBs */
|
||||
if (strstr (response, "Gauge: ")) {
|
||||
show = strstr (response, "Gauge: ") + 7;
|
||||
- is_numeric++;
|
||||
}
|
||||
else if (strstr (response, "Gauge32: ")) {
|
||||
show = strstr (response, "Gauge32: ") + 9;
|
||||
- is_numeric++;
|
||||
}
|
||||
else if (strstr (response, "Counter32: ")) {
|
||||
show = strstr (response, "Counter32: ") + 11;
|
||||
- is_numeric++;
|
||||
is_counter=1;
|
||||
if(!calculate_rate)
|
||||
strcpy(type, "c");
|
||||
}
|
||||
else if (strstr (response, "Counter64: ")) {
|
||||
show = strstr (response, "Counter64: ") + 11;
|
||||
- is_numeric++;
|
||||
is_counter=1;
|
||||
if(!calculate_rate)
|
||||
strcpy(type, "c");
|
||||
}
|
||||
else if (strstr (response, "INTEGER: ")) {
|
||||
show = strstr (response, "INTEGER: ") + 9;
|
||||
- is_numeric++;
|
||||
}
|
||||
else if (strstr (response, "STRING: ")) {
|
||||
show = strstr (response, "STRING: ") + 8;
|
||||
@@ -396,15 +390,17 @@ main (int argc, char **argv)
|
||||
}
|
||||
|
||||
}
|
||||
- else if (strstr (response, "Timeticks: "))
|
||||
+ else if (strstr (response, "Timeticks: ")) {
|
||||
show = strstr (response, "Timeticks: ");
|
||||
+ }
|
||||
else
|
||||
show = response;
|
||||
|
||||
iresult = STATE_DEPENDENT;
|
||||
|
||||
/* Process this block for numeric comparisons */
|
||||
- if (is_numeric) {
|
||||
+ /* Make some special values,like Timeticks numeric only if a threshold is defined */
|
||||
+ if (thlds[i]->warning || thlds[i]->critical || calculate_rate) {
|
||||
ptr = strpbrk (show, "0123456789");
|
||||
if (ptr == NULL)
|
||||
die (STATE_UNKNOWN,_("No valid data returned"));
|
||||
diff --git a/plugins/t/check_snmp.t b/plugins/t/check_snmp.t
|
||||
index 004ba1a..25a2999 100644
|
||||
--- a/plugins/t/check_snmp.t
|
||||
+++ b/plugins/t/check_snmp.t
|
||||
@@ -8,7 +8,7 @@ use strict;
|
||||
use Test::More;
|
||||
use NPTest;
|
||||
|
||||
-my $tests = 8+38+2+2;
|
||||
+my $tests = 8+42+2+2;
|
||||
plan tests => $tests;
|
||||
my $res;
|
||||
|
||||
@@ -124,6 +124,13 @@ SKIP: {
|
||||
cmp_ok( $res->return_code, '==', 0, "Skipping all thresholds");
|
||||
like($res->output, '/^SNMP OK - \d+ \w+ \d+\s.*$/', "Skipping all thresholds, result printed rather than parsed");
|
||||
|
||||
+ $res = NPTest->testCmd( "./check_snmp -H $host_snmp -C $snmp_community -o system.sysUpTime.0 -c 1000000000: -u '1/100 sec'");
|
||||
+ cmp_ok( $res->return_code, '==', 2, "Timetick used as a threshold");
|
||||
+ like($res->output, '/^SNMP CRITICAL - \*\d+\* 1\/100 sec.*$/', "Timetick used as a threshold, parsed as numeric");
|
||||
+
|
||||
+ $res = NPTest->testCmd( "./check_snmp -H $host_snmp -C $snmp_community -o system.sysUpTime.0");
|
||||
+ cmp_ok( $res->return_code, '==', 0, "Timetick used as a string");
|
||||
+ like($res->output, '/^SNMP OK - Timeticks:\s\(\d+\)\s+(?:\d+ days?,\s+)?\d+:\d+:\d+\.\d+\s.*$/', "Timetick used as a string, result printed rather than parsed");
|
||||
}
|
||||
|
||||
# These checks need a complete command line. An invalid community is used so
|
||||
diff --git a/plugins/tests/check_snmp.t b/plugins/tests/check_snmp.t
|
||||
index e7ad192..c960f7b 100755
|
||||
--- a/plugins/tests/check_snmp.t
|
||||
+++ b/plugins/tests/check_snmp.t
|
||||
@@ -51,7 +51,10 @@ if ($ARGV[0] && $ARGV[0] eq "-d") {
|
||||
}
|
||||
}
|
||||
|
||||
-my $tests = 33;
|
||||
+# We should merge that with $ENV{'NPTEST_CACHE'}, use one dir for all test data
|
||||
+$ENV{'NAGIOS_PLUGIN_STATE_DIRECTORY'} ||= "/var/tmp";
|
||||
+
|
||||
+my $tests = 39;
|
||||
if (-x "./check_snmp") {
|
||||
plan tests => $tests;
|
||||
} else {
|
||||
@@ -106,7 +109,7 @@ like($res->output, '/'.quotemeta('SNMP OK - And now have fun with with this: \"C
|
||||
"And now have fun with with this: \"C:\\\\\"
|
||||
because we\'re not done yet!"').'/m', "Attempt to confuse parser No.3");
|
||||
|
||||
-system("rm /usr/local/nagios/var/check_snmp/*");
|
||||
+system("rm -f ".$ENV{'NAGIOS_PLUGIN_STATE_DIRECTORY'}."/check_snmp/*");
|
||||
$res = NPTest->testCmd( "./check_snmp -H 127.0.0.1 -C public -p $port_snmp -o .1.3.6.1.4.1.8072.3.2.67.10 --rate -w 600" );
|
||||
is($res->return_code, 0, "Returns OK");
|
||||
is($res->output, "No previous data to calculate rate - assume okay");
|
||||
@@ -170,5 +173,16 @@ $res = NPTest->testCmd( "./check_snmp -H 127.0.0.1 -C public -p $port_snmp -o .1
|
||||
is($res->return_code, 0, "OK as string doesn't match but inverted" );
|
||||
is($res->output, 'SNMP OK - "stringtests" | ', "OK as inverted string no match" );
|
||||
|
||||
+$res = NPTest->testCmd( "./check_snmp -H 127.0.0.1 -C public -p $port_snmp -o .1.3.6.1.4.1.8072.3.2.67.12 -w 4:5" );
|
||||
+is($res->return_code, 1, "Numeric in string test" );
|
||||
+is($res->output, 'SNMP WARNING - *3.5* | iso.3.6.1.4.1.8072.3.2.67.12=3.5 ', "WARNING threshold checks for string masquerading as number" );
|
||||
+
|
||||
+$res = NPTest->testCmd( "./check_snmp -H 127.0.0.1 -C public -p $port_snmp -o .1.3.6.1.4.1.8072.3.2.67.13" );
|
||||
+is($res->return_code, 0, "Not really numeric test" );
|
||||
+is($res->output, 'SNMP OK - "87.4startswithnumberbutshouldbestring" | ', "Check string with numeric start is still string" );
|
||||
+
|
||||
+$res = NPTest->testCmd( "./check_snmp -H 127.0.0.1 -C public -p $port_snmp -o .1.3.6.1.4.1.8072.3.2.67.14" );
|
||||
+is($res->return_code, 0, "Not really numeric test (trying best to fool it)" );
|
||||
+is($res->output, 'SNMP OK - "555\"I said\"" | ', "Check string with a double quote following is still a string (looks like the perl routine will always escape though)" );
|
||||
|
||||
|
||||
diff --git a/plugins/tests/check_snmp_agent.pl b/plugins/tests/check_snmp_agent.pl
|
||||
index 8784ab1..2ad8516 100644
|
||||
--- a/plugins/tests/check_snmp_agent.pl
|
||||
+++ b/plugins/tests/check_snmp_agent.pl
|
||||
@@ -33,9 +33,9 @@ ends with with this: C:\\';
|
||||
my $multilin5 = 'And now have fun with with this: "C:\\"
|
||||
because we\'re not done yet!';
|
||||
|
||||
-my @fields = (ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_UNSIGNED, ASN_UNSIGNED, ASN_COUNTER, ASN_COUNTER64, ASN_UNSIGNED, ASN_COUNTER, ASN_OCTET_STR);
|
||||
-my @values = ($multiline, $multilin2, $multilin3, $multilin4, $multilin5, 4294965296, 1000, 4294965296, uint64("18446744073709351616"), int(rand(2**32)), 64000, "stringtests");
|
||||
-my @incrts = (undef, undef, undef, undef, undef, 1000, -500, 1000, 100000, undef, 666, undef);
|
||||
+my @fields = (ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_UNSIGNED, ASN_UNSIGNED, ASN_COUNTER, ASN_COUNTER64, ASN_UNSIGNED, ASN_COUNTER, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR, ASN_OCTET_STR );
|
||||
+my @values = ($multiline, $multilin2, $multilin3, $multilin4, $multilin5, 4294965296, 1000, 4294965296, uint64("18446744073709351616"), int(rand(2**32)), 64000, "stringtests", "3.5", "87.4startswithnumberbutshouldbestring", '555"I said"' );
|
||||
+my @incrts = (undef, undef, undef, undef, undef, 1000, -500, 1000, 100000, undef, 666, undef, undef, undef, undef );
|
||||
|
||||
# Number of elements in our OID
|
||||
my $oidelts;
|
||||
|
37
debian/patches/13_check_smtp_greeting.dpatch
vendored
37
debian/patches/13_check_smtp_greeting.dpatch
vendored
|
@ -1,37 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 13_check_smtp_greeting.dpatch
|
||||
## Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
##
|
||||
## From: d16f3fb0a9bb37cc1ce73ef14b5de83e907ef23c Tue, 8 Feb 2011 16:07:52 +0000 (+0100)
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Tue, 8 Feb 2011 16:07:52 +0000 (+0100)
|
||||
## Subject: [PATCH] check_smtp: Abort on missing/unexpected greeting
|
||||
## (Debian #611914)
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug%2Fnagiosplug;a=commitdiff_plain;h=d16f3fb0a9bb37cc1ce73ef14b5de83e907ef23c
|
||||
##
|
||||
## DP: Abort on missing/unexpected greeting (http://bugs.debian.org/611914)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
diff --git a/plugins/check_smtp.c b/plugins/check_smtp.c
|
||||
index 3da724b..ed49163 100644
|
||||
--- a/plugins/check_smtp.c
|
||||
+++ b/plugins/check_smtp.c
|
||||
@@ -183,7 +183,7 @@ main (int argc, char **argv)
|
||||
/* return a WARNING status if we couldn't read any data */
|
||||
if (recvlines(buffer, MAX_INPUT_BUFFER) <= 0) {
|
||||
printf (_("recv() failed\n"));
|
||||
- result = STATE_WARNING;
|
||||
+ return STATE_WARNING;
|
||||
}
|
||||
else {
|
||||
if (verbose)
|
||||
@@ -197,7 +197,7 @@ main (int argc, char **argv)
|
||||
else
|
||||
printf (_("Invalid SMTP response received from host on port %d: %s\n"),
|
||||
server_port, buffer);
|
||||
- result = STATE_WARNING;
|
||||
+ return STATE_WARNING;
|
||||
}
|
||||
}
|
||||
|
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
|
@ -1,27 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 14_check_icmp_multiple_ips.dpatch
|
||||
## Sebastian Harl <sh@teamix.net>
|
||||
##
|
||||
## From: 1374f80872412b64bd13f17e6edd70aa59437012 Mon Sep 17 00:00:00 2001
|
||||
## From: Sebastian Harl <sh@teamix.net>
|
||||
## Date: Thu, 28 Apr 2011 09:18:21 +0200
|
||||
## Subject: [PATCH] check_host: Allocate a large-enough buffer for the host table.
|
||||
## (Debian #623702)
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=1374f80872412b64bd13f17e6edd70aa59437012
|
||||
##
|
||||
## DP: Allocate a large-enough buffer for the host table. (http://bugs.debian.org/623702)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins-root/check_icmp.c
|
||||
+++ b/plugins-root/check_icmp.c
|
||||
@@ -621,7 +621,7 @@ main(int argc, char **argv)
|
||||
}
|
||||
|
||||
host = list;
|
||||
- table = malloc(sizeof(struct rta_host **) * (argc - 1));
|
||||
+ table = malloc(sizeof(struct rta_host **) * targets);
|
||||
i = 0;
|
||||
while(host) {
|
||||
host->id = i*packets;
|
||||
|
40
debian/patches/15_check_sensors_fault.dpatch
vendored
40
debian/patches/15_check_sensors_fault.dpatch
vendored
|
@ -1,40 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 15_check_sensors_fault.dpatch by Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
##
|
||||
## From 276c5b98bf619eabd8b0bd5fc3ff60c0a59489a7 Mon Sep 17 00:00:00 2001
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Wed, 7 Sep 2011 13:55:53 +0200
|
||||
## Subject: [PATCH] check_sensors: Detect FAULT status
|
||||
##
|
||||
## DP: Return an UNKNOWN status if a faulty sensor is detected. This can be
|
||||
## suppressed with the new "--ignore-fault" option.
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins-scripts/check_sensors.sh
|
||||
+++ b/plugins-scripts/check_sensors.sh
|
||||
@@ -10,7 +10,7 @@ REVISION="@NP_VERSION@"
|
||||
|
||||
|
||||
print_usage() {
|
||||
- echo "Usage: $PROGNAME"
|
||||
+ echo "Usage: $PROGNAME" [--ignore-fault]
|
||||
}
|
||||
|
||||
print_help() {
|
||||
@@ -57,9 +57,12 @@ case "$1" in
|
||||
if echo ${sensordata} | egrep ALARM > /dev/null; then
|
||||
echo SENSOR CRITICAL - Sensor alarm detected!
|
||||
exit 2
|
||||
- else
|
||||
- echo sensor ok
|
||||
- exit 0
|
||||
+ elif echo ${sensordata} | egrep FAULT > /dev/null \
|
||||
+ && test "$1" != "-i" -a "$1" != "--ignore-fault"; then
|
||||
+ echo SENSOR UNKNOWN - Sensor reported fault
|
||||
+ exit 3
|
||||
fi
|
||||
+ echo sensor ok
|
||||
+ exit 0
|
||||
;;
|
||||
esac
|
|
@ -1,24 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 16_check_raduis_fix_format-security.dpatch
|
||||
## From 055b2570eddff9a312dc1445bb7de4a6d7c4887d Mon Sep 17 00:00:00 2001
|
||||
## From: Thomas Guyot-Sionnest <dermoth@aei.ca>
|
||||
## Date: Tue, 6 Sep 2011 23:20:21 -0400
|
||||
## Subject: [PATCH] Make GCC happy
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=055b2570eddff9a312dc1445bb7de4a6d7c4887d
|
||||
##
|
||||
## DP: It won't trust us about msg containing no format string, and fail miserably
|
||||
## when compiled with -Werror=format-security. (https://bugs.launchpad.net/bugs/837085)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_radius.c
|
||||
+++ b/plugins/check_radius.c
|
||||
@@ -211,7 +211,7 @@ main (int argc, char **argv)
|
||||
if (result == OK_RC)
|
||||
die (STATE_OK, _("Auth OK"));
|
||||
(void)snprintf(msg, sizeof(msg), _("Unexpected result code %d"), result);
|
||||
- die (STATE_UNKNOWN, msg);
|
||||
+ die (STATE_UNKNOWN, "%s", msg);
|
||||
}
|
||||
|
||||
|
|
@ -1,24 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 17_check_smtp_fix_duplicate_cert_message.dpatch
|
||||
## From 4d06603060fc1233861b164870f0d3a2e0d8d2eb Fri, 15 Jul 2011 20:19:15 +0000 (+0100)
|
||||
## From: Ton Voon <ton.voon@opsera.com>
|
||||
## Date: Tue, 6 Sep 2011 23:20:21 -0400
|
||||
## Subject: [PATCH] Fix check_smtp and check_tcp where duplicate messages were displayed for certificate...
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=4d06603060fc1233861b164870f0d3a2e0d8d2eb
|
||||
##
|
||||
## DP: Fix check_smtp where duplicate messages were displayed for certificate errors
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_smtp.c
|
||||
+++ b/plugins/check_smtp.c
|
||||
@@ -276,9 +276,6 @@ main (int argc, char **argv)
|
||||
# ifdef USE_OPENSSL
|
||||
if ( check_cert ) {
|
||||
result = np_net_ssl_check_cert(days_till_exp);
|
||||
- if(result != STATE_OK){
|
||||
- printf ("%s\n", _("CRITICAL - Cannot retrieve server certificate."));
|
||||
- }
|
||||
my_close();
|
||||
return result;
|
||||
}
|
|
@ -1,28 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 17_check_tcp_fix_duplicate_cert_message.dpatch
|
||||
## From 4d06603060fc1233861b164870f0d3a2e0d8d2eb Fri, 15 Jul 2011 20:19:15 +0000 (+0100)
|
||||
## From: Ton Voon <ton.voon@opsera.com>
|
||||
## Date: Tue, 6 Sep 2011 23:20:21 -0400
|
||||
## Subject: [PATCH] Fix check_smtp and check_tcp where duplicate messages were displayed for certificate...
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=4d06603060fc1233861b164870f0d3a2e0d8d2eb
|
||||
##
|
||||
## DP: Fix check_tcp where duplicate messages were displayed for certificate errors
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_tcp.c
|
||||
+++ b/plugins/check_tcp.c
|
||||
@@ -236,12 +236,9 @@ main (int argc, char **argv)
|
||||
result = np_net_ssl_init(sd);
|
||||
if (result == STATE_OK && check_cert == TRUE) {
|
||||
result = np_net_ssl_check_cert(days_till_exp);
|
||||
- if(result != STATE_OK) {
|
||||
- printf(_("CRITICAL - Cannot retrieve server certificate.\n"));
|
||||
- }
|
||||
}
|
||||
}
|
||||
- if(result != STATE_OK){
|
||||
+ if(result != STATE_OK || check_cert == TRUE){
|
||||
np_net_ssl_cleanup();
|
||||
if(sd) close(sd);
|
||||
return result;
|
34
debian/patches/18_check_snmp_labels.dpatch
vendored
34
debian/patches/18_check_snmp_labels.dpatch
vendored
|
@ -1,34 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 18_check_snmp_labels.dpatch
|
||||
## From 0e3fa54782f8cbb47af058c4bf13688e8b23865b Mon Sep 17 00:00:00 2001
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Fri, 24 Feb 2012 12:29:00 +0100
|
||||
## Subject: [PATCH] Accept multiple labels specified with "-l"
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=patch;h=0e3fa54782f8cbb47af058c4bf13688e8b23865b
|
||||
##
|
||||
## DP: check_snmp: fix multiple labels. (http://bugs.debian.org/647020)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_snmp.c
|
||||
+++ b/plugins/check_snmp.c
|
||||
@@ -749,7 +749,7 @@ process_arguments (int argc, char **argv)
|
||||
if (labels == NULL)
|
||||
die (STATE_UNKNOWN, _("Could not reallocate labels\n"));
|
||||
}
|
||||
- labels++;
|
||||
+ nlabels++;
|
||||
ptr = thisarg (ptr);
|
||||
if (strstr (ptr, "'") == ptr)
|
||||
labels[nlabels - 1] = ptr + 1;
|
||||
@@ -1072,8 +1072,8 @@ print_help (void)
|
||||
|
||||
printf ("\n");
|
||||
printf ("%s\n", _("Notes:"));
|
||||
- printf (" %s\n", _("- Multiple OIDs may be indicated by a comma or space-delimited list (lists with"));
|
||||
- printf (" %s %i %s\n", _("internal spaces must be quoted). Maximum:"), MAX_OIDS, _("OIDs."));
|
||||
+ printf (" %s\n", _("- Multiple OIDs (and labels) may be indicated by a comma or space-delimited "));
|
||||
+ printf (" %s %i %s\n", _("list (lists with internal spaces must be quoted). Maximum:"), MAX_OIDS, _("OIDs."));
|
||||
|
||||
printf(" -%s", UT_THRESHOLDS_NOTES);
|
||||
|
26
debian/patches/19_check_http_help.dpatch
vendored
26
debian/patches/19_check_http_help.dpatch
vendored
|
@ -1,26 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 18_check_snmp_labels.dpatch
|
||||
## From d796c16327e6e315dd528f17e8bd597c5f506730 Mon Sep 17 00:00:00 2001
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Fri, 24 Feb 2012 13:24:56 +0100
|
||||
## Subject: [PATCH] Clarify that check_http won't verify certificates
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=patch;h=d796c16327e6e315dd528f17e8bd597c5f506730
|
||||
##
|
||||
## DP: check_http: clarify that check_http won't verify certificates (http://bugs.debian.org/644627)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_http.c
|
||||
+++ b/plugins/check_http.c
|
||||
@@ -1400,6 +1400,10 @@ print_help (void)
|
||||
printf (" %s\n", _("serve content (optionally within a specified time) or whether the X509 "));
|
||||
printf (" %s\n", _("certificate is still valid for the specified number of days."));
|
||||
printf ("\n");
|
||||
+ printf (" %s\n", _("Please note that this plugin does not check if the presented server"));
|
||||
+ printf (" %s\n", _("certificate matches the hostname of the server, or if the certificate"));
|
||||
+ printf (" %s\n", _("has a valid chain of trust to one of the locally installed CAs."));
|
||||
+ printf ("\n");
|
||||
printf ("%s\n", _("Examples:"));
|
||||
printf (" %s\n\n", "CHECK CONTENT: check_http -w 5 -c 10 --ssl -H www.verisign.com");
|
||||
printf (" %s\n", _("When the 'www.verisign.com' server returns its content within 5 seconds,"));
|
||||
|
Loading…
Reference in a new issue