LC_NUMERIC fix for check_procs
This commit is contained in:
parent
06b7682676
commit
8bd868ec49
9
debian/changelog
vendored
9
debian/changelog
vendored
|
@ -1,10 +1,13 @@
|
|||
nagios-plugins (1.4.2-7) unstable; urgency=high
|
||||
nagios-plugins (1.4.2-7) unstable; urgency=medium
|
||||
|
||||
[sean finney]
|
||||
* update build dependencies to build against libmysqlclient15-dev.
|
||||
fixes (now) rc bug, urgency thus set to high.
|
||||
fixes (now) rc bug, urgency bumped (closes: #343785).
|
||||
* properly set LC_NUMERIC in check_procs. fix also committed for
|
||||
next upstream release. thanks to Hadmut Danisch for
|
||||
catching this (closes: #353201).
|
||||
|
||||
-- sean finney <seanius@debian.org> Sat, 18 Feb 2006 13:47:54 +0100
|
||||
-- sean finney <seanius@debian.org> Sat, 18 Feb 2006 13:56:25 +0100
|
||||
|
||||
nagios-plugins (1.4.2-6) unstable; urgency=low
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -13,3 +13,4 @@
|
|||
21_de.po_fixes.dpatch
|
||||
22_check_smb_hostaddress.dpatch
|
||||
23_check_axis.dpatch
|
||||
24_check_procs_localefix.dpatch
|
||||
|
|
17
debian/patches/24_check_procs_localefix.dpatch
vendored
Executable file
17
debian/patches/24_check_procs_localefix.dpatch
vendored
Executable file
|
@ -0,0 +1,17 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 24_check_procs_localefix.dpatch by <seanius@debian.org>
|
||||
##
|
||||
## DP: make sure LC_NUMERIC is properly set because the plugin parses output
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-1.4.2~/plugins/check_procs.c nagios-plugins-1.4.2/plugins/check_procs.c
|
||||
--- nagios-plugins-1.4.2~/plugins/check_procs.c 2005-09-15 10:27:58.000000000 +0200
|
||||
+++ nagios-plugins-1.4.2/plugins/check_procs.c 2006-02-18 13:52:13.000000000 +0100
|
||||
@@ -116,6 +116,7 @@
|
||||
setlocale (LC_ALL, "");
|
||||
bindtextdomain (PACKAGE, LOCALEDIR);
|
||||
textdomain (PACKAGE);
|
||||
+ setlocale (LC_NUMERIC, "POSIX");
|
||||
|
||||
input_buffer = malloc (MAX_INPUT_BUFFER);
|
||||
procprog = malloc (MAX_INPUT_BUFFER);
|
Loading…
Reference in a new issue