fix raid levels with more than one digit
This commit is contained in:
parent
354922bdcb
commit
8f0c07fa46
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -25,6 +25,8 @@ nagios-plugins (1.4.14-1) unstable; urgency=low
|
|||
- Add 41_check_ping_detect_args.dpatch, that to Thomas Guyot-Sionnest
|
||||
* Add hint to NEWS.Debian, that check_linux_raid.pl and check_bgpstate will
|
||||
be removed in the next future
|
||||
* Add 42_check_linux_raid_fix_r10.dpatch, which fixes RAID Levels with more
|
||||
than one digit, thanks to Matija Nalis (Closes: #534604)
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Sat, 05 Dec 2009 02:46:35 +0100
|
||||
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -16,3 +16,4 @@
|
|||
39_check_ircd_fix_epn.dpatch
|
||||
40_check_http_proxy_auth.dpatch
|
||||
41_check_ping_detect_args.dpatch
|
||||
42_check_linux_raid_fix_r10.dpatch
|
||||
|
|
18
debian/patches/42_check_linux_raid_fix_r10.dpatch
vendored
Executable file
18
debian/patches/42_check_linux_raid_fix_r10.dpatch
vendored
Executable file
|
@ -0,0 +1,18 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 42_check_linux_raid_fix_r10.dpatch by Matija Nalis <mnalis-debianbug@voyager.hr>
|
||||
##
|
||||
## DP: Make Raid10+ working
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-1.4.14~/contrib/check_linux_raid.pl nagios-plugins-1.4.14/contrib/check_linux_raid.pl
|
||||
--- nagios-plugins-1.4.14~/contrib/check_linux_raid.pl 2009-12-08 19:46:00.000000000 +0100
|
||||
+++ nagios-plugins-1.4.14/contrib/check_linux_raid.pl 2009-12-08 19:46:31.000000000 +0100
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
my $nextdev;
|
||||
if(defined $ARGV[0]) { $nextdev = shift; }
|
||||
-else { $nextdev = "md[0-9]"; }
|
||||
+else { $nextdev = "md[0-9]+"; }
|
||||
|
||||
my $code = "UNKNOWN";
|
||||
my $msg = "";
|
Loading…
Reference in a new issue