add check_linux_raid
This commit is contained in:
parent
af42444698
commit
97803e4b14
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -46,6 +46,8 @@ nagios-plugins (1.4.12-1) UNRELEASED; urgency=low
|
|||
anyways, thanks Josip Rodin <joy@debbugs.entuzijast.net> for profiding a
|
||||
fix (Closes: #482942)
|
||||
* mention the check_radius breakerage in NEWS.Debian
|
||||
* add check_linux_raid into package (Closes: #461999) and add
|
||||
38_fix_libexec.dpatch to fix libexec path
|
||||
|
||||
[ Alexander Wirt ]
|
||||
* Call smbclient with -N (supress password prompt) if no password is
|
||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -12,4 +12,5 @@
|
|||
35_check_http_date.dpatch
|
||||
36_check_ldap_empty_base.dpatch
|
||||
37_check_radius_nas-ip-address.dpatch
|
||||
38_fix_libexec.dpatch
|
||||
50_misc_typos.dpatch
|
||||
|
|
18
debian/patches/38_fix_libexec.dpatch
vendored
Executable file
18
debian/patches/38_fix_libexec.dpatch
vendored
Executable file
|
@ -0,0 +1,18 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 38_fix_libexec.dpatch by Jan Wagner <waja@cyconet.org>
|
||||
##
|
||||
## DP: fix library path
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-1.4.12~/contrib/check_linux_raid.pl nagios-plugins-1.4.12/contrib/check_linux_raid.pl
|
||||
--- nagios-plugins-1.4.12~/contrib/check_linux_raid.pl 2007-08-28 05:19:45.000000000 +0200
|
||||
+++ nagios-plugins-1.4.12/contrib/check_linux_raid.pl 2008-06-06 16:16:23.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
# WARNING md0 status=[UUU_U], recovery=46.4%, finish=123.0min
|
||||
|
||||
use strict;
|
||||
-use lib "/usr/local/nagios/libexec";
|
||||
+use lib "/usr/lib/nagios/plugins";
|
||||
use utils qw(%ERRORS);
|
||||
|
||||
# die with an error if we're not on Linux
|
1
debian/rules
vendored
1
debian/rules
vendored
|
@ -145,6 +145,7 @@ install: build
|
|||
done
|
||||
# install check_bgpstate from contrib
|
||||
install -m 755 contrib/check_bgpstate.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_bgpstate
|
||||
install -m 755 contrib/check_linux_raid.pl ${NP_STD_DIR}/${NP_LIBEXEC}/check_linux_raid
|
||||
# dynamically create the postrm scripts using a template, so that we
|
||||
# don't have to define the same list of plugin configs over and over.
|
||||
sed -e 's/@BASIC_PLUGINS@/${basic_plugin_cfgs}/' \
|
||||
|
|
Loading…
Reference in a new issue