fix for #623702
This commit is contained in:
parent
94b4b82d48
commit
a48887cae5
6
debian/changelog
vendored
6
debian/changelog
vendored
|
@ -5,6 +5,12 @@ nagios-plugins (1.4.15-4) UNRELEASED; urgency=low
|
||||||
- Abort immediately if we don't receive a server greeting or if the
|
- Abort immediately if we don't receive a server greeting or if the
|
||||||
greeting doesn't contain the "--expect"ed string (by default: "220")
|
greeting doesn't contain the "--expect"ed string (by default: "220")
|
||||||
instead of blindly sending the EHLO/HELO line.
|
instead of blindly sending the EHLO/HELO line.
|
||||||
|
* Add 14_check_icmp_multiple_ips.dpatch (Closes: #623702), thanks Max Kosmach
|
||||||
|
for spotting and Sebastian Harl for providing a fix
|
||||||
|
- When specifying a host-name on the command line, each of its IPs is added
|
||||||
|
to the host table (and each one is pinged). So, the buffer has to be large
|
||||||
|
enough to hold all of the respective host objects. (argc - 1) only fits
|
||||||
|
hosts with a single IP.
|
||||||
* Move libraries linked at compile time against checks of
|
* Move libraries linked at compile time against checks of
|
||||||
nagios-plugins-standard from Depends to Recommends (Closes: #569028)
|
nagios-plugins-standard from Depends to Recommends (Closes: #569028)
|
||||||
- Add slightly modified bin/gen_plugin_deps.pl from collectd source package
|
- Add slightly modified bin/gen_plugin_deps.pl from collectd source package
|
||||||
|
|
1
debian/patches/00list
vendored
1
debian/patches/00list
vendored
|
@ -6,3 +6,4 @@
|
||||||
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
11_check_disk_smb_NT_STATUS_ACCESS_DENIED.dpatch
|
||||||
12_check_snmp_1.4.15_regression.dpatch
|
12_check_snmp_1.4.15_regression.dpatch
|
||||||
13_check_smtp_greeting.dpatch
|
13_check_smtp_greeting.dpatch
|
||||||
|
14_check_icmp_multiple_ips.dpatch
|
||||||
|
|
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
27
debian/patches/14_check_icmp_multiple_ips.dpatch
vendored
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 14_check_icmp_multiple_ips.dpatch
|
||||||
|
## Sebastian Harl <sh@teamix.net>
|
||||||
|
##
|
||||||
|
## From: 1374f80872412b64bd13f17e6edd70aa59437012 Mon Sep 17 00:00:00 2001
|
||||||
|
## From: Sebastian Harl <sh@teamix.net>
|
||||||
|
## Date: Thu, 28 Apr 2011 09:18:21 +0200
|
||||||
|
## Subject: [PATCH] check_host: Allocate a large-enough buffer for the host table.
|
||||||
|
## (Debian #623702)
|
||||||
|
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=commitdiff_plain;h=1374f80872412b64bd13f17e6edd70aa59437012
|
||||||
|
##
|
||||||
|
## DP: Allocate a large-enough buffer for the host table. (http://bugs.debian.org/623702)
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
|
||||||
|
--- a/plugins-root/check_icmp.c
|
||||||
|
+++ b/plugins-root/check_icmp.c
|
||||||
|
@@ -621,7 +621,7 @@ main(int argc, char **argv)
|
||||||
|
}
|
||||||
|
|
||||||
|
host = list;
|
||||||
|
- table = malloc(sizeof(struct rta_host **) * (argc - 1));
|
||||||
|
+ table = malloc(sizeof(struct rta_host **) * targets);
|
||||||
|
i = 0;
|
||||||
|
while(host) {
|
||||||
|
host->id = i*packets;
|
||||||
|
|
Loading…
Reference in a new issue