drop 26_implicit-basename.dpatch

This commit is contained in:
Jan Wagner 2010-04-09 18:53:23 +00:00
parent 0728e90759
commit b5272998dc
3 changed files with 3 additions and 19 deletions

4
debian/changelog vendored
View file

@ -2,7 +2,9 @@ nagios-plugins (1.4.14-5) UNRELEASED; urgency=low
* Adding links to bugreports into most of the patches * Adding links to bugreports into most of the patches
* Dropping patches not needed anymore: * Dropping patches not needed anymore:
- 14_check_log_paths.dpatch - 14_check_log_paths.dpatch: paths are fine now
- 26_implicit-basename.dpatch: no 'implicitly convertion' found in buildlog
without the patch
-- Jan Wagner <waja@cyconet.org> Thu, 08 Apr 2010 23:54:05 +0200 -- Jan Wagner <waja@cyconet.org> Thu, 08 Apr 2010 23:54:05 +0200

View file

@ -4,7 +4,6 @@
18_check_game_cmdline.dpatch 18_check_game_cmdline.dpatch
22_check_smb_hostaddress.dpatch 22_check_smb_hostaddress.dpatch
23_check_smb_password.dpatch 23_check_smb_password.dpatch
26_implicit-basename.dpatch
27_check_radius_segfault.dpatch 27_check_radius_segfault.dpatch
32_check_ldap_pointer.dpatch 32_check_ldap_pointer.dpatch
33_fix_emb_check_disk_smb.dpatch 33_fix_emb_check_disk_smb.dpatch

View file

@ -1,17 +0,0 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 26-implicit-basename.dpatch by <seanius@localhost.localdomain>
##
## DP: Fix for implicit definition of basename function. (bugs.debian.org/396814)
@DPATCH@
diff -urNad nagios-plugins-1.4.4~/plugins/check_procs.c nagios-plugins-1.4.4/plugins/check_procs.c
--- nagios-plugins-1.4.4~/plugins/check_procs.c 2006-10-19 02:25:16.000000000 +0200
+++ nagios-plugins-1.4.4/plugins/check_procs.c 2006-11-17 09:26:57.000000000 +0100
@@ -45,6 +45,7 @@
#include "utils.h"
#include <pwd.h>
+#include <dirname.h>
int process_arguments (int, char **);
int validate_arguments (void);