make use of old libldap API

This commit is contained in:
Jan Wagner 2008-03-06 10:00:15 +00:00
parent d8a6072c8a
commit b59a29946b
3 changed files with 21 additions and 0 deletions

2
debian/changelog vendored
View file

@ -5,6 +5,8 @@ nagios-plugins (1.4.11-2) UNRELEASED; urgency=low
(Closes: #429778)
* fix check_disk --local by adding 31_check_disk_local_option.dpatch
(Closes: #405537)
* define LDAP_DEPRECATED in check_ldap.c to make use of old API by adding
32_check_ldap_pointer.dpatch (Closes: #463322)
-- sean finney <seanius@debian.org> Sat, 26 Jan 2008 15:08:03 +0100

View file

@ -9,4 +9,5 @@
29_check_ntp_fixsefault_deprecate.dpatch
30_fix_check_ntp_options.dpatch
31_check_disk_local_option.dpatch
32_check_ldap_pointer.dpatch
50_misc_typos.dpatch

View file

@ -0,0 +1,18 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 32_check_ldap_pointer.dpatch by Jan Wagner <waja@cyconet.org>
## patch provided by dann frazier <dannf@debian.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Using deprecated interfaces of libldap API
@DPATCH@
--- nagios-plugins-1.4.11.orig/plugins/check_ldap.c 2007-07-07 16:20:40.000000000 -0600
+++ nagios-plugins-1.4.11/plugins/check_ldap.c 2008-01-30 15:14:14.000000000 -0700
@@ -42,6 +42,7 @@
#include "utils.h"
#include <lber.h>
+#define LDAP_DEPRECATED 1
#include <ldap.h>
enum {