fix for various regressions in the last security upload
This commit is contained in:
parent
9b4a8d00a1
commit
c22280dc63
13
debian/changelog
vendored
13
debian/changelog
vendored
|
@ -1,3 +1,16 @@
|
|||
nagios-plugins (1.4-6sarge2) UNRELEASED; urgency=high
|
||||
|
||||
* NMU prepared for the security team by the package maintainer.
|
||||
* Fix the following regressions in the previous security upload:
|
||||
- check_procs/check_nagios/check_swap all fail to build correctly unless
|
||||
/proc is mounted, so fail gracefully in that case. closes: #465530
|
||||
- check_mailq may default to /usr/sbin/mailq instead of /usr/bin/mailq
|
||||
if the the ssmtp package is installed at build-time. closes: #465749.
|
||||
- check_ping may fail to build correctly due to assumptions about
|
||||
host configuration and/or network connectivity. closes: #465854.
|
||||
|
||||
-- Sean Finney <seanius@debian.org> Fri, 15 Feb 2008 20:30:57 +0100
|
||||
|
||||
nagios-plugins (1.4-6sarge1) oldstable-security; urgency=high
|
||||
|
||||
* Fix CVE-2007-5198
|
||||
|
|
2
debian/patches/00list
vendored
2
debian/patches/00list
vendored
|
@ -2,4 +2,4 @@
|
|||
06_checkircd
|
||||
08_subst
|
||||
09_pssyntax
|
||||
10_CVE-2007-5198
|
||||
10_CVE-2007-519811_hardcode_against_regressions
|
||||
|
|
20
debian/patches/11_hardcode_against_regressions.dpatch
vendored
Executable file
20
debian/patches/11_hardcode_against_regressions.dpatch
vendored
Executable file
|
@ -0,0 +1,20 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 11_hardcode_against_regressions.dpatch by <seanius@debian.org>
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
## DP: see #465749
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-sarge~/config.h.in nagios-plugins-sarge/config.h.in
|
||||
--- nagios-plugins-sarge~/config.h.in 2005-02-04 01:47:45.000000000 +0100
|
||||
+++ nagios-plugins-sarge/config.h.in 2008-02-15 20:16:36.000000000 +0100
|
||||
@@ -632,6 +632,9 @@
|
||||
|
||||
/* path to qmail-qstat */
|
||||
#undef PATH_TO_MAILQ
|
||||
+#ifndef PATH_TO_MAILQ
|
||||
+# define PATH_TO_MAILQ "/usr/bin/mailq"
|
||||
+#endif
|
||||
|
||||
/* path to ntpdate binary */
|
||||
#undef PATH_TO_NTPDATE
|
6
debian/rules
vendored
6
debian/rules
vendored
|
@ -32,8 +32,12 @@ endif
|
|||
config.status: configure
|
||||
export PATH=$(PATH)
|
||||
dh_testdir
|
||||
@if ! mount | grep -qw /proc; then \
|
||||
echo "E: /proc must be mounted" >&2 \
|
||||
exit 1
|
||||
fi
|
||||
# Add here commands to configure the package.
|
||||
CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib/nagios/plugins --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-df-command="/bin/df -Pk"
|
||||
CFLAGS="$(CFLAGS)" PATH_TO_MAILQ="/usr/bin/mailq" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib/nagios/plugins --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-df-command="/bin/df -Pk" --with-ping-command="/bin/ping -n -U -w %d -c %d %s" --with-ping6-command="/bin/ping6 -n -U -c %d %s"
|
||||
|
||||
build: patch-stamp build-stamp
|
||||
|
||||
|
|
Loading…
Reference in a new issue