fix check_disk --local, doesn't need an argument

This commit is contained in:
Jan Wagner 2008-02-05 21:31:32 +00:00
parent 8570a498bb
commit d8a6072c8a
3 changed files with 22 additions and 0 deletions

2
debian/changelog vendored
View file

@ -3,6 +3,8 @@ nagios-plugins (1.4.11-2) UNRELEASED; urgency=low
[ Jan Wagner ]
* Remove Build-depends on libsnmp*-dev since it's not needed anymore
(Closes: #429778)
* fix check_disk --local by adding 31_check_disk_local_option.dpatch
(Closes: #405537)
-- sean finney <seanius@debian.org> Sat, 26 Jan 2008 15:08:03 +0100

View file

@ -8,4 +8,5 @@
28_check_pgsql_include_for_8.3.dpatch
29_check_ntp_fixsefault_deprecate.dpatch
30_fix_check_ntp_options.dpatch
31_check_disk_local_option.dpatch
50_misc_typos.dpatch

View file

@ -0,0 +1,19 @@
#! /bin/sh /usr/share/dpatch/dpatch-run
## 31_check_disk_local_option.dpatch by Jan Wagner <waja@cyconet.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Fix local option for check_disk
@DPATCH@
diff -Nur nagios-plugins-1.4.11/plugins/check_disk.c.orig nagios-plugins-1.4.11/plugins/check_disk.c
--- nagios-plugins-1.4.11/plugins/check_disk.c.orig 2007-12-08 17:34:05.000000000 +0100
+++ nagios-plugins-1.4.11/plugins/check_disk.c 2008-02-05 22:13:43.397159697 +0100
@@ -475,7 +475,7 @@
{"iwarning", required_argument, 0, 'W'},
/* Dang, -C is taken. We might want to reshuffle this. */
{"icritical", required_argument, 0, 'K'},
- {"local", required_argument, 0, 'l'},
+ {"local", no_argument, 0, 'l'},
{"stat-remote-fs", required_argument, 0, 'L'},
{"kilobytes", required_argument, 0, 'k'},
{"megabytes", required_argument, 0, 'm'},