update ping fix for regression fix
This commit is contained in:
parent
a6f91a37b7
commit
e247081db9
|
@ -7,7 +7,7 @@
|
|||
@DPATCH@
|
||||
diff -urNad nagios-plugins-sarge~/config.h.in nagios-plugins-sarge/config.h.in
|
||||
--- nagios-plugins-sarge~/config.h.in 2005-02-04 01:47:45.000000000 +0100
|
||||
+++ nagios-plugins-sarge/config.h.in 2008-02-15 20:16:36.000000000 +0100
|
||||
+++ nagios-plugins-sarge/config.h.in 2008-02-15 21:33:07.000000000 +0100
|
||||
@@ -632,6 +632,9 @@
|
||||
|
||||
/* path to qmail-qstat */
|
||||
|
@ -18,3 +18,15 @@ diff -urNad nagios-plugins-sarge~/config.h.in nagios-plugins-sarge/config.h.in
|
|||
|
||||
/* path to ntpdate binary */
|
||||
#undef PATH_TO_NTPDATE
|
||||
diff -urNad nagios-plugins-sarge~/configure nagios-plugins-sarge/configure
|
||||
--- nagios-plugins-sarge~/configure 2008-02-15 21:33:07.000000000 +0100
|
||||
+++ nagios-plugins-sarge/configure 2008-02-15 21:35:06.000000000 +0100
|
||||
@@ -14347,7 +14347,7 @@
|
||||
|
||||
fi
|
||||
|
||||
-if test "x$ac_cv_ping_has_timeout" != "xno"
|
||||
+if test "x$ac_cv_ping_has_timeout" != "xno" || test -n "$PING_HAS_TIMEOUT"
|
||||
then
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
|
|
2
debian/rules
vendored
2
debian/rules
vendored
|
@ -37,7 +37,7 @@ config.status: configure
|
|||
exit 1; \
|
||||
fi
|
||||
# Add here commands to configure the package.
|
||||
CFLAGS="$(CFLAGS)" PATH_TO_MAILQ="/usr/bin/mailq" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib/nagios/plugins --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-df-command="/bin/df -Pk" --with-ping-command="/bin/ping -n -U -w %d -c %d %s" --with-ping6-command="/bin/ping6 -n -U -c %d %s"
|
||||
CFLAGS="$(CFLAGS)" PATH_TO_MAILQ="/usr/bin/mailq" PING_HAS_TIMEOUT=1 ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib/nagios/plugins --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-df-command="/bin/df -Pk" --with-ping-command="/bin/ping -n -U -w %d -c %d %s" --with-ping6-command="/bin/ping6 -n -U -c %d %s"
|
||||
|
||||
build: patch-stamp build-stamp
|
||||
|
||||
|
|
Loading…
Reference in a new issue