* upstream now uses libtool, but the shipped libtool is out of date and
has problems building against radiusclient1-dev (which might not be our fault, but...). so, for the time being we're shipping an updated version of ltmain.sh in the diff (build depending on the newest version of libtool is subobtimal for backporting). * add --disable-rpath to configure options... arg, and i had to apply another patch to ./configure to keep a -R from sneaking in and deactivating it. * upstream ./configure fails to automagically detect mysql installation now, so modify debian/rules accordingly. * modify debian/control to be more explicit about build-dependencies to make life easier for backporting.
This commit is contained in:
parent
2a3c7a1d0c
commit
ea66194ad7
14
debian/changelog
vendored
14
debian/changelog
vendored
|
@ -19,8 +19,20 @@ nagios-plugins (1.4.3-1) unstable; urgency=low
|
|||
- 18_check_game_cmdline.dpatch
|
||||
* removed the transitional (pre-sarge) fileutils dependency
|
||||
(closes: #368718), thanks to Stefan Huehner for pointing this out.
|
||||
* upstream now uses libtool, but the shipped libtool is out of date and
|
||||
has problems building against radiusclient1-dev (which might not be
|
||||
our fault, but...). so, for the time being we're shipping an updated
|
||||
version of ltmain.sh in the diff (build depending on the newest version
|
||||
of libtool is subobtimal for backporting).
|
||||
* add --disable-rpath to configure options... arg, and i had to apply
|
||||
another patch to ./configure to keep a -R from sneaking in and
|
||||
deactivating it.
|
||||
* upstream ./configure fails to automagically detect mysql installation now,
|
||||
so modify debian/rules accordingly.
|
||||
* modify debian/control to be more explicit about build-dependencies to
|
||||
make life easier for backporting.
|
||||
|
||||
-- sean finney <seanius@debian.org> Wed, 24 May 2006 17:48:00 +0200
|
||||
-- sean finney <seanius@debian.org> Sat, 27 May 2006 20:03:31 +0200
|
||||
|
||||
nagios-plugins (1.4.2-7) unstable; urgency=medium
|
||||
|
||||
|
|
2
debian/control
vendored
2
debian/control
vendored
|
@ -3,7 +3,7 @@ Section: net
|
|||
Priority: extra
|
||||
Maintainer: Debian Nagios Maintainer Group <pkg-nagios-devel@lists.alioth.debian.org>
|
||||
Uploaders: sean finney <seanius@debian.org>, Guido Trotter <ultrotter@debian.org>
|
||||
Build-Depends: debhelper (>= 4.0.0), dpatch (>= 2.0.9), autotools-dev, libldap2-dev, postgresql-dev, libmysqlclient15-dev | libmysqlclient-dev, libsnmp9-dev | libsnmp-dev, libradius1-dev, libkrb5-dev, libnet-snmp-perl, procps, coreutils, iputils-ping, snmp, mawk | awk
|
||||
Build-Depends: debhelper (>= 4.0.0), dpatch (>= 2.0.9), autotools-dev, libldap2-dev, postgresql-dev, libmysqlclient15-dev | libmysqlclient12-dev | libmysqlclient-dev, libsnmp9-dev | libsnmp5-dev | libsnmp-dev, libradius1-dev, libkrb5-dev, libnet-snmp-perl, procps, coreutils, iputils-ping, snmp, mawk | awk
|
||||
Standards-Version: 3.6.2
|
||||
|
||||
Package: nagios-plugins
|
||||
|
|
36
debian/patches/10_config.h_debiandefaults.dpatch
vendored
36
debian/patches/10_config.h_debiandefaults.dpatch
vendored
|
@ -5,10 +5,10 @@
|
|||
## DP: No description.
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad nagios-plugins-1.4.2~/configure nagios-plugins-1.4.2/configure
|
||||
--- nagios-plugins-1.4.2~/configure 2005-09-19 15:58:16.000000000 +0200
|
||||
+++ nagios-plugins-1.4.2/configure 2006-01-23 18:45:39.000000000 +0100
|
||||
@@ -7760,7 +7760,7 @@
|
||||
diff -urNad --exclude=CVS --exclude=.svn ./configure /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/configure
|
||||
--- ./configure 2006-04-19 05:52:19.000000000 +0200
|
||||
+++ /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/configure 2006-05-27 21:30:13.000000000 +0200
|
||||
@@ -23466,7 +23466,7 @@
|
||||
fi;
|
||||
|
||||
|
||||
|
@ -17,9 +17,17 @@ diff -urNad nagios-plugins-1.4.2~/configure nagios-plugins-1.4.2/configure
|
|||
|
||||
LDFLAGS="$LDFLAGS -L."
|
||||
|
||||
diff -urNad nagios-plugins-1.4.2~/np-debian.h nagios-plugins-1.4.2/np-debian.h
|
||||
--- nagios-plugins-1.4.2~/np-debian.h 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ nagios-plugins-1.4.2/np-debian.h 2006-01-23 18:24:07.000000000 +0100
|
||||
@@ -27037,7 +27037,6 @@
|
||||
unset FOUNDINCLUDE
|
||||
if test x"$with_openssl" != x"/usr" ; then
|
||||
CPPFLAGS="$CPPFLAGS -I$with_openssl/include"
|
||||
- LDFLAGS="$LDFLAGS -R$with_openssl/lib"
|
||||
fi
|
||||
|
||||
|
||||
diff -urNad --exclude=CVS --exclude=.svn ./np-debian.h /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/np-debian.h
|
||||
--- ./np-debian.h 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/np-debian.h 2006-05-27 21:29:42.000000000 +0200
|
||||
@@ -0,0 +1,25 @@
|
||||
+#ifndef _NP_DEBIAN_H_
|
||||
+#define _NP_DEBIAN_H_
|
||||
|
@ -46,10 +54,10 @@ diff -urNad nagios-plugins-1.4.2~/np-debian.h nagios-plugins-1.4.2/np-debian.h
|
|||
+#define PATH_TO_NTPQ "/usr/bin/ntpq"
|
||||
+
|
||||
+#endif /* _NP_DEBIAN_H_ */
|
||||
diff -urNad nagios-plugins-1.4.2~/plugins/common.h nagios-plugins-1.4.2/plugins/common.h
|
||||
--- nagios-plugins-1.4.2~/plugins/common.h 2004-12-10 01:13:43.000000000 +0100
|
||||
+++ nagios-plugins-1.4.2/plugins/common.h 2006-01-23 18:24:07.000000000 +0100
|
||||
@@ -33,6 +33,7 @@
|
||||
diff -urNad --exclude=CVS --exclude=.svn ./plugins/common.h /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/plugins/common.h
|
||||
--- ./plugins/common.h 2005-12-07 16:10:27.000000000 +0100
|
||||
+++ /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/plugins/common.h 2006-05-27 21:29:42.000000000 +0200
|
||||
@@ -36,6 +36,7 @@
|
||||
#define _COMMON_H_
|
||||
|
||||
#include "config.h"
|
||||
|
@ -57,9 +65,9 @@ diff -urNad nagios-plugins-1.4.2~/plugins/common.h nagios-plugins-1.4.2/plugins/
|
|||
|
||||
#ifdef HAVE_FEATURES_H
|
||||
#include <features.h>
|
||||
diff -urNad nagios-plugins-1.4.2~/plugins-scripts/utils.pm.in nagios-plugins-1.4.2/plugins-scripts/utils.pm.in
|
||||
--- nagios-plugins-1.4.2~/plugins-scripts/utils.pm.in 2003-04-13 06:25:36.000000000 +0200
|
||||
+++ nagios-plugins-1.4.2/plugins-scripts/utils.pm.in 2006-01-23 18:24:07.000000000 +0100
|
||||
diff -urNad --exclude=CVS --exclude=.svn ./plugins-scripts/utils.pm.in /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/plugins-scripts/utils.pm.in
|
||||
--- ./plugins-scripts/utils.pm.in 2003-04-13 06:25:36.000000000 +0200
|
||||
+++ /home/sean/tmp/dpep-work.XeNnAd/nagios-plugins-1.4.3/plugins-scripts/utils.pm.in 2006-05-27 21:29:42.000000000 +0200
|
||||
@@ -35,13 +35,13 @@
|
||||
sub is_hostname;
|
||||
|
||||
|
|
2
debian/rules
vendored
2
debian/rules
vendored
|
@ -49,7 +49,7 @@ config.status: configure
|
|||
rm -f config.cache
|
||||
|
||||
# Add here commands to configure the package.
|
||||
EXTRAS="check_game check_fping check_by_ssh check_dig check_dns" PATH_TO_DIG="/usr/bin/dig" PATH_TO_NSLOOKUP="/usr/bin/nslookup" NSLOOKUP_COMMAND="/usr/bin/nslookup -sil" PATH_TO_HOST="/usr/bin/host" CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=${NP_LIBEXEC} --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-df-command="/bin/df -Pk"
|
||||
EXTRAS="check_game check_fping check_by_ssh check_dig check_dns" PATH_TO_DIG="/usr/bin/dig" PATH_TO_NSLOOKUP="/usr/bin/nslookup" NSLOOKUP_COMMAND="/usr/bin/nslookup -sil" PATH_TO_HOST="/usr/bin/host" CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=${NP_LIBEXEC} --with-nagios-user=nagios --with-nagios-group=nagios --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin --with-mysql=/usr --disable-rpath
|
||||
|
||||
build: patch-stamp build-stamp
|
||||
|
||||
|
|
Loading…
Reference in a new issue