new upstream (snapshot)
This commit is contained in:
parent
67e4560a2b
commit
fdbe22492c
9
debian/changelog
vendored
9
debian/changelog
vendored
|
@ -1,6 +1,11 @@
|
|||
nagios-plugins (1.4.16-4) UNRELEASED; urgency=low
|
||||
nagios-plugins (1.4.16+git20130823-1) UNRELEASED; urgency=low
|
||||
|
||||
* NOT RELEASED YET
|
||||
* New upstream git snapshot (fae168a68b)
|
||||
* Droped the following upstream integrated patches
|
||||
- 05_fix_gets_undefined_in_iso_c11.dpatch
|
||||
- 10_check_apt_perfdata.dpatch
|
||||
- 11_check_nt_npe.dpatch
|
||||
- 12_check_smtp_double_threshold.dpatch
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Fri, 23 Aug 2013 22:45:43 +0200
|
||||
|
||||
|
|
5
debian/patches/00list
vendored
5
debian/patches/00list
vendored
|
@ -1,7 +1,2 @@
|
|||
02_check_icmp_links.dpatch
|
||||
05_fix_gets_undefined_in_iso_c11.dpatch
|
||||
# commited upstream
|
||||
10_check_apt_perfdata.dpatch
|
||||
11_check_nt_npe.dpatch
|
||||
12_check_smtp_double_threshold.dpatch
|
||||
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 17_fix_gets_undefined_in_iso_c11.dpatch by <ubuntu@server-e76384a2-51cb-4595-9b66-9ed53c1e0c44.canonistack>
|
||||
##
|
||||
## All lines beginning with `## DP:' are a description of the patch.
|
||||
##
|
||||
## DP: Do not assume that gets is defined. gets got dropped in ISO C11,
|
||||
## DP: but the embedded old version of gnulib assumes it is defined. Since Ubuntu
|
||||
## DP: now does not define gets, it is safe to disable this warning, which fixes the
|
||||
## DP: FTBFS.
|
||||
## DP:
|
||||
## DP: Author: Robie Basak <robie.basak@canonical.com>
|
||||
## DP: Bug: http://sourceforge.net/support/tracker.php?aid=3600122
|
||||
## DP: Bug-Ubuntu: https://launchpad.net/bugs/1097848
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.15~/gl/stdio.in.h nagios-plugins-1.4.15/gl/stdio.in.h
|
||||
--- nagios-plugins-1.4.15~/gl/stdio.in.h 2010-07-27 20:47:15.000000000 +0000
|
||||
+++ nagios-plugins-1.4.15/gl/stdio.in.h 2013-01-09 17:17:13.112864259 +0000
|
||||
@@ -141,7 +141,14 @@
|
||||
so any use of gets warrants an unconditional warning. Assume it is
|
||||
always declared, since it is required by C89. */
|
||||
#undef gets
|
||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
+
|
||||
+/* gets is no longer defined in ISO C11. This has been updated in upstream
|
||||
+ * gnulib:
|
||||
+ * http://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff;h=66712c23388e93e5c518ebc8515140fa0c807348
|
||||
+ * Since Ubuntu now does not define gets, it is safe to disable this warning.
|
||||
+ * https://launchpad.net/bugs/1097848
|
||||
+ * _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
||||
+ */
|
||||
|
||||
#if @GNULIB_FOPEN@
|
||||
# if @REPLACE_FOPEN@
|
39
debian/patches/10_check_apt_perfdata.dpatch
vendored
39
debian/patches/10_check_apt_perfdata.dpatch
vendored
|
@ -1,39 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 10_check_apt_perfdata.dpatch by Jan Wagner <waja@cyconet.org>
|
||||
##
|
||||
## From 93c1dcba62b6499bef97a6cc9a274eb049de634a Mon Sep 17 00:00:00 2001
|
||||
## From: Jan Wagner <waja@cyconet.org>
|
||||
## Date: Tue, 25 Jun 2013 11:11:41 +0200
|
||||
## Subject: [PATCH] Fixed SF.net bug 1614553, Debian bug #708343, Adding
|
||||
## performace data
|
||||
|
||||
@DPATCH@
|
||||
---
|
||||
plugins/check_apt.c | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/plugins/check_apt.c b/plugins/check_apt.c
|
||||
index 7ec2d55..433055b 100644
|
||||
--- a/plugins/check_apt.c
|
||||
+++ b/plugins/check_apt.c
|
||||
@@ -116,7 +116,7 @@ int main (int argc, char **argv) {
|
||||
result = max_state(result, STATE_OK);
|
||||
}
|
||||
|
||||
- printf(_("APT %s: %d packages available for %s (%d critical updates). %s%s%s%s\n"),
|
||||
+ printf(_("APT %s: %d packages available for %s (%d critical updates). %s%s%s%s|available_upgrades=%d;;;0 critical_updates=%d;;;0\n"),
|
||||
state_text(result),
|
||||
packages_available,
|
||||
(upgrade==DIST_UPGRADE)?"dist-upgrade":"upgrade",
|
||||
@@ -124,7 +124,9 @@ int main (int argc, char **argv) {
|
||||
(stderr_warning)?" warnings detected":"",
|
||||
(stderr_warning && exec_warning)?",":"",
|
||||
(exec_warning)?" errors detected":"",
|
||||
- (stderr_warning||exec_warning)?". run with -v for information.":""
|
||||
+ (stderr_warning||exec_warning)?". run with -v for information.":"",
|
||||
+ packages_available,
|
||||
+ sec_count
|
||||
);
|
||||
|
||||
return result;
|
||||
|
46
debian/patches/11_check_nt_npe.dpatch
vendored
46
debian/patches/11_check_nt_npe.dpatch
vendored
|
@ -1,46 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 11_check_nt_npe.dpatch by Vaclav Ovsik <vaclav.ovsik@i.cz>
|
||||
##
|
||||
## DP: Fixes some NULL pointer dereference in check_nt.
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.16~/plugins/check_nt.c nagios-plugins-1.4.16/plugins/check_nt.c
|
||||
--- nagios-plugins-1.4.16~/plugins/check_nt.c 2013-06-29 18:11:20.000000000 +0200
|
||||
+++ nagios-plugins-1.4.16/plugins/check_nt.c 2013-06-29 18:22:52.000000000 +0200
|
||||
@@ -94,6 +94,7 @@
|
||||
char *description=NULL,*counter_unit = NULL;
|
||||
char *minval = NULL, *maxval = NULL, *errcvt = NULL;
|
||||
char *fds=NULL, *tds=NULL;
|
||||
+ char *numstr;
|
||||
|
||||
double total_disk_space=0;
|
||||
double free_disk_space=0;
|
||||
@@ -265,7 +266,10 @@
|
||||
asprintf(&send_buffer,"%s&%u&%s&%s", req_password,(vars_to_check==CHECK_SERVICESTATE)?5:6,
|
||||
(show_all==TRUE) ? "ShowAll" : "ShowFail",value_list);
|
||||
fetch_data (server_address, server_port, send_buffer);
|
||||
- return_code=atoi(strtok(recv_buffer,"&"));
|
||||
+ numstr = strtok(recv_buffer,"&");
|
||||
+ if (numstr == NULL)
|
||||
+ die(STATE_UNKNOWN, _("could not fetch information from server\n"));
|
||||
+ return_code=atoi(numstr);
|
||||
temp_string=strtok(NULL,"&");
|
||||
output_message = strdup (temp_string);
|
||||
}
|
||||
@@ -275,8 +279,14 @@
|
||||
|
||||
asprintf(&send_buffer,"%s&7", req_password);
|
||||
fetch_data (server_address, server_port, send_buffer);
|
||||
- mem_commitLimit=atof(strtok(recv_buffer,"&"));
|
||||
- mem_commitByte=atof(strtok(NULL,"&"));
|
||||
+ numstr = strtok(recv_buffer,"&");
|
||||
+ if (numstr == NULL)
|
||||
+ die(STATE_UNKNOWN, _("could not fetch information from server\n"));
|
||||
+ mem_commitLimit=atof(numstr);
|
||||
+ numstr = strtok(NULL,"&");
|
||||
+ if (numstr == NULL)
|
||||
+ die(STATE_UNKNOWN, _("could not fetch information from server\n"));
|
||||
+ mem_commitByte=atof(numstr);
|
||||
percent_used_space = (mem_commitByte / mem_commitLimit) * 100;
|
||||
warning_used_space = ((float)warning_value / 100) * mem_commitLimit;
|
||||
critical_used_space = ((float)critical_value / 100) * mem_commitLimit;
|
|
@ -1,73 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 12_check_smtp_double_threshold.dpatch by Roman Fiedler
|
||||
##
|
||||
## From 9839a1b9945400bb4a00a1dd9858d1c98267b284 Mon Sep 17 00:00:00 2001
|
||||
## From: Jan Wagner <waja@cyconet.org>
|
||||
## Date: Thu, 11 Jul 2013 14:11:09 +0200
|
||||
## Subject: [PATCH] Fixed SF.net bug 2555775, threshold can be double for
|
||||
## check_smtp
|
||||
##
|
||||
## DP: Adds threshold in double to check_smtp
|
||||
|
||||
@DPATCH@
|
||||
diff --git a/plugins/check_smtp.c b/plugins/check_smtp.c
|
||||
index 79fa482..d477a51 100644
|
||||
--- a/plugins/check_smtp.c
|
||||
+++ b/plugins/check_smtp.c
|
||||
@@ -99,9 +99,9 @@ enum {
|
||||
char *authtype = NULL;
|
||||
char *authuser = NULL;
|
||||
char *authpass = NULL;
|
||||
-int warning_time = 0;
|
||||
+double warning_time = 0;
|
||||
int check_warning_time = FALSE;
|
||||
-int critical_time = 0;
|
||||
+double critical_time = 0;
|
||||
int check_critical_time = FALSE;
|
||||
int verbose = 0;
|
||||
int use_ssl = FALSE;
|
||||
@@ -417,9 +417,9 @@ enum {
|
||||
elapsed_time = (double)microsec / 1.0e6;
|
||||
|
||||
if (result == STATE_OK) {
|
||||
- if (check_critical_time && elapsed_time > (double) critical_time)
|
||||
+ if (check_critical_time && elapsed_time > critical_time)
|
||||
result = STATE_CRITICAL;
|
||||
- else if (check_warning_time && elapsed_time > (double) warning_time)
|
||||
+ else if (check_warning_time && elapsed_time > warning_time)
|
||||
result = STATE_WARNING;
|
||||
}
|
||||
|
||||
@@ -552,21 +552,19 @@ enum {
|
||||
nresponses++;
|
||||
break;
|
||||
case 'c': /* critical time threshold */
|
||||
- if (is_intnonneg (optarg)) {
|
||||
- critical_time = atoi (optarg);
|
||||
- check_critical_time = TRUE;
|
||||
- }
|
||||
+ if (!is_nonnegative (optarg))
|
||||
+ usage4 (_("Critical time must be a positive"));
|
||||
else {
|
||||
- usage4 (_("Critical time must be a positive integer"));
|
||||
+ critical_time = strtod (optarg, NULL);
|
||||
+ check_critical_time = TRUE;
|
||||
}
|
||||
break;
|
||||
case 'w': /* warning time threshold */
|
||||
- if (is_intnonneg (optarg)) {
|
||||
- warning_time = atoi (optarg);
|
||||
- check_warning_time = TRUE;
|
||||
- }
|
||||
+ if (!is_nonnegative (optarg))
|
||||
+ usage4 (_("Warning time must be a positive"));
|
||||
else {
|
||||
- usage4 (_("Warning time must be a positive integer"));
|
||||
+ warning_time = strtod (optarg, NULL);
|
||||
+ check_warning_time = TRUE;
|
||||
}
|
||||
break;
|
||||
case 'v': /* verbose */
|
||||
--
|
||||
1.8.1.6
|
||||
|
Loading…
Reference in a new issue