patch accepted upstream
This commit is contained in:
parent
117e9973f7
commit
49bd4b96a7
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -11,7 +11,7 @@ nagios-plugins (1.4.15-6) UNRELEASED; urgency=low
|
|||
* Add build-arch and build-indep targets to debian/rules
|
||||
* Add 03_check_disk_smb_perfdata.dpatch to add perfdata to check_disk_smb
|
||||
(Closes: #654259), thanks to G. Leimua
|
||||
* Add 04_check_snmp_labels.dpatch to fix multiple labels in check_snmp
|
||||
* Add 18_check_snmp_labels.dpatch to fix multiple labels in check_snmp
|
||||
(Closes: #647020), thanks to Oskar Liljeblad
|
||||
|
||||
-- Jan Wagner <waja@cyconet.org> Wed, 07 Sep 2011 15:33:55 +0200
|
||||
|
|
2
debian/patches/00list
vendored
2
debian/patches/00list
vendored
|
@ -1,6 +1,5 @@
|
|||
01_subst.in.dpatch
|
||||
02_check_icmp_links.dpatch
|
||||
04_check_snmp_labels.dpatch
|
||||
# commited upstream
|
||||
05_check_linux_raid_fix_striped.dpatch
|
||||
10_check_disk_smb_spaces.dpatch
|
||||
|
@ -13,3 +12,4 @@
|
|||
17_check_tcp_fix_duplicate_cert_message.dpatch
|
||||
17_check_smtp_fix_duplicate_cert_message.dpatch
|
||||
03_check_disk_smb_perfdata.dpatch
|
||||
18_check_snmp_labels.dpatch
|
||||
|
|
18
debian/patches/04_check_snmp_labels.dpatch
vendored
18
debian/patches/04_check_snmp_labels.dpatch
vendored
|
@ -1,18 +0,0 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 04_check_snmp_labels.dpatch by Oskar Liljeblad <oskar@osk.mine.nu>
|
||||
##
|
||||
## DP: check_snmp: fix multiple labels. (http://bugs.debian.org/647020)
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' nagios-plugins-1.4.15~/plugins/check_snmp.c nagios-plugins-1.4.15/plugins/check_snmp.c
|
||||
--- nagios-plugins-1.4.15~/plugins/check_snmp.c 2010-07-27 22:47:16.000000000 +0200
|
||||
+++ nagios-plugins-1.4.15/plugins/check_snmp.c 2012-02-24 01:08:16.000000000 +0100
|
||||
@@ -753,7 +753,7 @@
|
||||
if (labels == NULL)
|
||||
die (STATE_UNKNOWN, _("Could not reallocate labels\n"));
|
||||
}
|
||||
- labels++;
|
||||
+ nlabels++;
|
||||
ptr = thisarg (ptr);
|
||||
if (strstr (ptr, "'") == ptr)
|
||||
labels[nlabels - 1] = ptr + 1;
|
34
debian/patches/18_check_snmp_labels.dpatch
vendored
Executable file
34
debian/patches/18_check_snmp_labels.dpatch
vendored
Executable file
|
@ -0,0 +1,34 @@
|
|||
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||
## 18_check_snmp_labels.dpatch
|
||||
## From 0e3fa54782f8cbb47af058c4bf13688e8b23865b Mon Sep 17 00:00:00 2001
|
||||
## From: Holger Weiss <holger@zedat.fu-berlin.de>
|
||||
## Date: Fri, 24 Feb 2012 12:29:00 +0100
|
||||
## Subject: [PATCH] Accept multiple labels specified with "-l"
|
||||
## X-Git-Url: http://nagiosplug.git.sourceforge.net/git/gitweb.cgi?p=nagiosplug/nagiosplug;a=patch;h=0e3fa54782f8cbb47af058c4bf13688e8b23865b
|
||||
##
|
||||
## DP: check_snmp: fix multiple labels. (http://bugs.debian.org/647020)
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- a/plugins/check_snmp.c
|
||||
+++ b/plugins/check_snmp.c
|
||||
@@ -749,7 +749,7 @@ process_arguments (int argc, char **argv)
|
||||
if (labels == NULL)
|
||||
die (STATE_UNKNOWN, _("Could not reallocate labels\n"));
|
||||
}
|
||||
- labels++;
|
||||
+ nlabels++;
|
||||
ptr = thisarg (ptr);
|
||||
if (strstr (ptr, "'") == ptr)
|
||||
labels[nlabels - 1] = ptr + 1;
|
||||
@@ -1072,8 +1072,8 @@ print_help (void)
|
||||
|
||||
printf ("\n");
|
||||
printf ("%s\n", _("Notes:"));
|
||||
- printf (" %s\n", _("- Multiple OIDs may be indicated by a comma or space-delimited list (lists with"));
|
||||
- printf (" %s %i %s\n", _("internal spaces must be quoted). Maximum:"), MAX_OIDS, _("OIDs."));
|
||||
+ printf (" %s\n", _("- Multiple OIDs (and labels) may be indicated by a comma or space-delimited "));
|
||||
+ printf (" %s %i %s\n", _("list (lists with internal spaces must be quoted). Maximum:"), MAX_OIDS, _("OIDs."));
|
||||
|
||||
printf(" -%s", UT_THRESHOLDS_NOTES);
|
||||
|
Loading…
Reference in a new issue